第 2 章 – 工作流程
模型树的三个页签、一般工作顺序,以及每个顶部菜单包含什么。
在 Solvix 中,模型树的三个选项卡决定了本软件的工作流程:
- 几何 – 几何编辑和网格生成,
- FEM 模型 – 分析设置(前处理),
- 结果 – 后处理。
每个选项卡还会在顶部工具栏中激活相应的菜单。

图 2: Solvix 模型选项卡
在 Solvix 中工作时通常应遵循的步骤如下:
- 新建模型(文件 > 新建),并选择模型空间和单位制。
- 导入用于分析的 CAD/STL 几何或网格(文件 > 导入)。对于 2D 分析,零件必须作为完全位于 XY 平面内的面导入。此外,对于轴对称分析,表示零件的面必须位于 Y 轴右侧。零件名称旁的带白色感叹号的黄色三角形表示几何可能存在需要进一步检查和修复的问题(应在导入 Solvix 之前在 CAD 软件中修复)。
- 对于 CAD 和 STL 几何,准备网格设置(网格 > 网格设置项 > 创建)并生成网格(网格 > 创建网格)。也可以在不使用网格设置项的情况下生成网格——此时将使用默认设置。
- 网格创建成功后,进入模型树的 FEM 模型 部分。
- 为分析定义材料(材料 > 创建),添加适当的材料行为:弹性、密度(用于执行模态分析或使用重力或离心载荷)、塑性(用于考虑永久变形)、热学或滑移磨损。
- 使用先前定义的材料创建新截面(截面 > 创建)。截面类型可以是实体(用于 3D 或 2D 实体单元)、壳(用于壳单元)或膜(用于膜单元)。如果使用壳、膜或平面应力/应变单元,还必须指定厚度。选择零件以将截面赋予该零件。
- 创建新的分析步。在大多数情况下,默认的步骤设置已足够。
- 可选:创建约束(约束 > 创建),定义接触(展开接触容器,选择表面相互作用 > 创建,然后选择接触对 > 创建),初始条件(初始条件 > 创建),定义场(定义场 > 创建)和/或幅值(幅值 > 创建)。
- 定义边界条件(边界条件 > 创建)和载荷(载荷 > 创建)。可用的类型有多种,并且可以以不同方式施加到模型上(后文将讨论)。
- 提交分析(分析-1 > 运行),分析完成后即可查看结果(分析-1 > 结果)。各种后处理选项将在后文说明。
在 Solvix 中,可以使用节点集和单元集以及表面来工作。它们可以在创建任何边界条件、载荷、约束或接触之前定义,然后在所选功能的定义中引用。不过,通常更倾向于在不预先创建集/表面的情况下添加功能。在这种情况下,功能窗口中的选择工具将根据功能类型,让用户基于几何或网格选择实体。
在 Solvix 中工作有两种主要方式——使用菜单(菜单栏和顶部工具栏)中可用的选项,或在模型树中选择它们。某些更高级的选项只能从菜单栏访问。
Solvix 中的视图控制:
- 缩放:鼠标滚轮;
- 旋转模型:鼠标中键或键盘方向键;
- 平移(移动模型):Shift + 鼠标中键。
在零件上任意位置按下鼠标中键,即可将该位置移至屏幕中心,并将其设为旋转中心。
进行选择时,使用鼠标左键(拖动鼠标以使用选择框——只有完全位于框内的项才会被选中)。选择时按住 Shift 可添加实体,按住 Ctrl 可移除实体。
三个主选项卡的上方各有一个搜索栏。它可用于筛选几何、FEM 模型和结果树。
使用单位的输入字段支持单位换算。用户可以输入数值,编辑显示的默认单位(例如将 MPa 改为 GPa),按下 Enter 后即完成换算,Solvix 将以默认单位显示该数值。
在发生故障时(Solvix 突然关闭),程序会询问是否使用崩溃恢复文件来恢复先前的会话。
Solvix 支持对某些在图形界面中尚未实现前处理功能的分析进行后处理,即灵敏度分析和涉及状态变量(SDV)的仿真结果可以进行可视化。

图 3: Solvix 主工具栏
文件菜单
文件菜单包含以下选项:
- 新建(Ctrl + N)– 创建新模型。模型空间可以是 3D、2D 平面应力、2D 平面应变或 2D 轴对称。可用的单位制如下(选择单位制后列出导出单位):
- 无单位,
- m、kg、s、°C – 标准 SI 单位,
- mm、ton、s、°C – 机械工程常用的单位组合,
- m、ton、s、°C,
- in、lbf · s 2/in、s、°F – 英制单位。
- 打开(Ctrl + O)– 打开先前创建的模型(.svx)、历史记录(.svxh)、Solvix 结果(.frd)或 OpenFOAM 文件(.foam)
- 最近打开 – 打开最近使用过的模型之一,或清除最近文件列表。
- 运行历史文件 – 运行 .svxh 文件。
- 导入(Ctrl + I)– 导入以下列格式之一保存的 CAD 几何、网格或模型:
- STEP:.stp 和 .step(大多数情况下推荐使用),
- IGES:.igs 和 .iges,
- B-rep:.brep,
- 立体光刻:.stl,
- 通用格式:.unv,
- Netgen:.vol,
- Abaqus/Solvix 输入文件:.inp,
- Mmg 网格:.mesh。
- 保存(Ctrl + S)– 保存当前模型中的更改。
- 另存为 – 以给定名称将模型保存为 .svx 文件。
- 导出 – 以以下格式之一导出零件/模型:
- STEP:.stp,
- B-rep:.brep,
- 立体光刻:.stl,
- Solvix 输入文件:.inp,
- Abaqus 输入文件(实验性):.inp,
- Mmg 网格:.mesh,
- 变形网格:.inp(遵循当前的变形比例因子,当壳单元分析的输出设置为 3D 时导出实体单元),
- 变形可视化:.stl(遵循当前的变形比例因子)。
- 关闭当前结果 – 关闭模型树后处理部分中当前显示的结果(在不含结果的情况下保存 .svx 模型可减小文件体积)。
- 关闭所有结果 – 关闭模型树后处理部分中的所有结果(在不含结果的情况下保存 svx 模型可减小文件体积)。
- 退出(Ctrl + F4)– 关闭 Solvix(程序会先询问是否保存模型)。
编辑菜单
编辑菜单包含以下选项:
- 撤销 – 撤销上一步操作。
- 重做 – 重做先前撤销的操作。
- 编辑历史记录 – 打开历史记录编辑器,可查看已执行操作的历史,并通过选择该行的第一列并按 Delete 键删除所选的命令条目。可使用清除全部按钮删除整个历史记录。更改历史记录会改变“重新生成”功能的行为,因此应谨慎使用。清除很长的历史记录可能有助于提高 Solvix 的响应速度,因为每添加一条新命令(即每向模型添加一个功能)后,历史记录都会保存到文件中。
- 重新生成模型 – 重新生成模型(仅重新生成模型命令——分析和后处理命令不会重新生成)。
- 使用其他文件重新生成模型 – 用另一文件中的相似几何替换模型的几何,从而无需重新定义模型(仅重新生成模型命令——分析和后处理命令不会重新生成)。
- 带重新划分网格的重新生成模型 – 重新划分模型网格,同时保留所有使用基于网格的选择定义的节点集、单元集和表面数据——模型可以在无需重新定义基于几何的选择的情况下重新划分网格(仅重新生成模型命令——分析和后处理命令不会重新生成)。
- 全部重新生成 – 重新生成模型(所有命令)。
- 使用其他文件全部重新生成 – 用另一文件中的相似几何替换模型的几何,从而无需重新定义模型(所有命令)。
- 带重新划分网格的全部重新生成 – 重新划分模型网格,同时保留所有使用基于网格的选择定义的节点集、单元集和表面数据——模型可以在无需重新定义基于几何的选择的情况下重新划分网格(所有命令)。
视图菜单
视图菜单包含以下选项:
- 标准视图 – 应用以下预定义视图之一:
- 前视图或后视图,
- 顶视图或底视图,
- 左视图或右视图,
- 法向、– 竖直,
- 等轴测。
- 缩放到适合 – 缩放模型,使其适合窗口。
- 线框 – 应用仅显示模型边线的视图。
- 显示单元边 – 应用显示带有限元单元边的模型的视图。
- 显示模型边 – 应用显示模型及其特征边的视图。
- 无边 – 应用不显示任何边的模型视图。
- 剖视图 – 使用由点和法向定义的平面剖切模型,或禁用剖视图(此选项也可在后处理中使用)——注意:在几何选项卡中使用剖视图时,即使是实体零件也会显示为空心。
- 爆炸视图 – 以爆炸视图显示装配零件 – 有两种方法可用:
- 默认:爆炸视图方向、放大倍数、比例因子,
- 中心点:X/Y/Z 坐标、爆炸视图方向、放大倍数、比例因子。
- 全部显示 – 显示(取消隐藏)模型的所有零件。
- 全部隐藏 – 隐藏模型的所有零件。
- 反转可见零件 – 反转零件的可见性。
- 未变形 – 在结果中显示未变形模型。
- 变形 – 在结果中显示变形模型。
- 带彩色云图的变形 – 在结果中显示带云图的变形模型。
- 变形 & 彩色 & 线框 – 在结果中显示带云图和未变形模型线框表示的变形模型。
- 变形 & 彩色 & 实体 – 在结果中显示带云图和未变形模型实体表示的变形模型。
- 颜色标注 – 根据各种标准使用颜色区分模型中的项:面朝向、零件、材料、截面、截面厚度、所有符号、参考点、约束、接触对、边界条件、载荷。

图 4: 文件和视图工具栏
文件菜单和视图菜单中选定的选项可通过图 4 所示的工具栏菜单直接访问。该工具栏还包含用于查询和标注的两个按钮,将在后文讨论。
工具菜单
工具菜单包含以下选项:
- 设置 – 要将下列任一选项卡中的所有设置恢复为默认值,请在空白处右键单击并选择恢复全部
- 常规
- 打开上次的文件、上次的文件名。
- 将结果保存在 .svx 文件中。
- 压缩 .svx 文件:无压缩、最快、最优。
- 默认单位制。
- 导入网格 → 边角。
- 图形
- 背景:类型、顶部颜色、底部颜色。
- 几何:CAD 偏差。
- 光照:环境光分量、漫射光分量。
- 平滑:点平滑、线平滑。
- 控件:坐标系可见性、比例控件可见性。
- 默认颜色
- 面朝向:正面颜色、背面颜色。
- 常规。
- 标注
- 设计:背景类型、绘制边框矩形、数字格式、有效数字位数
- 边/面标注:显示边/面 id、显示边/面类型、显示边/面尺寸、显示最大值、显示最小值、显示总和值、显示平均值
- 节点标注:显示节点 id、显示坐标
- 零件标注:显示零件名称、显示零件 id、显示零件类型、显示单元数量、显示节点数量
- 网格划分 – 网格划分的默认设置
- 网格尺寸:网格尺寸定义、最大单元因子、最小单元因子、渐变,
- 每边单元数、每曲率单元数、Hausdorff 因子,
- 网格优化:2D 优化步数、3D 优化步数,
- 网格类型:二阶、几何上的中间节点、以四边形为主的网格,
- 网格操作:分割组合网格、合并组合零件、保留模型边。
- 前处理
- 颜色条:背景类型、绘制边框矩形。
- 选择:默认几何选择模式、主/次/鼠标悬停高亮颜色。
- 符号:约束/边界条件/载荷颜色、符号尺寸、节点符号尺寸、绘制符号边线。
- 求解器
- 求解器:工作目录、使用 .svx 文件夹作为工作目录、可执行文件、默认求解器。
- 并行化:处理器数量、环境变量。
- 实验性:将金字塔单元转换为(退化楔形/退化六面体)
- 后处理
- 未变形模型
- 绘制未变形模型:无/线框主体/实体主体,
- 未变形模型颜色。
- 极限值
- 显示最小值位置:是/否,
- 显示最大值位置:是/否。
- 历史输出
- 历史输出条目上限。
- 未变形模型
- 图例
- 颜色谱设置
- 颜色谱类型:冷暖、彩虹、低饱和彩虹、暖色、冷色、Cividis、Viridis、Plasma、黑体、Inferno、KindImann、灰度,
- 亮度,
- 反转颜色:是/否,
- 离散颜色数量 – 范围为 2-24。
- 颜色谱数值
- 数字格式:科学计数/常规,
- 有效数字位数 – 范围为 2-8,· 最小/最大极限类型:自动/手动。
- 设计
- 背景类型:无/白色,
- 绘制边框矩形:是/否。
- 颜色谱设置
- 状态块
- 设计
- 状态块可见性:是/否,
- 背景类型:无/白色,
- 绘制边框矩形:开/关。
- 设计
- 参数
- 名称
- 数值/方程
- 计算结果
- 查询
- 顶点/节点 – 检查顶点/节点 ID、坐标以及该节点中当前显示场输出的数值(在结果中)。
- 面片/单元 – 检查面片/单元 ID。
- 边 – 检查边 ID 及其长度,以及该边上当前显示场输出的最大值、最小值和总值(在结果中)。
- 表面 – 检查表面 ID 及其面积,以及该表面上当前显示场输出的最大值、最小值和总值(在结果中)
- 零件 – 检查零件信息(名称、id、类型、单元数和节点数)。
- 装配 – 检查零件数、单元数和节点数。
- 包围盒尺寸 – 检查模型包围盒的尺寸。
- 距离 – 测量两个节点之间的距离。
- 角度 – 使用三个点测量角度。
- 圆 – 测量通过所选三个点的圆的半径。
- 查找
- 项类型:顶点/节点、面片/单元、边、表面、零件。
- 数据:添加标注、项 id。
目前,使用查询菜单创建的大多数标注不仅在 Solvix 窗口底部的消息区中显示输出,还会以附着在模型上的标签形式显示。右键单击这些标签会显示编辑(手动更改显示内容)、重置和删除选项。通过这种方式还可以访问设置菜单,在其中可以对标注进一步调整。单击查询窗口底部的清除按钮会删除所有可见的标注(可以同时显示多个不同类型的标注)。文件和视图工具栏上还有一个“移除标注”按钮(图 6)。其旁边是“查询”按钮,它是工具 查询 的快捷方式。此外,标注会保存在 .svx 文件中。
查找工具可用于定位(高亮显示)具有指定 ID 的几何和网格实体。例如,当需要查找求解器报告为存在问题的节点或单元时,该工具会很有用。
可以定义无单位参数,然后在参考点、材料、截面、约束、载荷和边界条件定义的方程中引用这些参数。要添加方程,应在输入字段开头键入等号 = 并删除该字段中的单位。方程使用开源的 Ncalc 库,因此支持其函数。
