Handbuch / Kapitel 2 – Arbeitsablauf

Kapitel 2 – Arbeitsablauf

Die drei Register des Modellbaums, die übliche Arbeitsreihenfolge und der Inhalt jedes oberen Menüs.

MANUAL CH. 34 ABSCHNITTE17 MIN. LESEZEITAKTUALISIERT 2025-10-20

In Solvix bestimmen drei Registerkarten des Modellbaums den Arbeitsablauf:

  • Geometry – Bearbeitung der Geometrie und Vernetzung,
  • FEM Model – Einrichten der Analyse (Pre-Processing),
  • Results – Post-Processing.

Jede Registerkarte aktiviert außerdem die passenden Menüs in der oberen Symbolleiste.

Abbildung 2: Modellregisterkarten in Solvix

Die allgemeinen Schritte, die bei der Arbeit mit Solvix zu befolgen sind, sind unten aufgeführt:

  1. Neues Modell anlegen ( File > New ) und Modellraum sowie Einheitensystem auswählen.
  2. CAD-/STL-Geometrie oder Netz für die Analyse importieren ( File > Import ). Für 2D-Analysen müssen Bauteile als Flächen importiert werden, die vollständig in der XY-Ebene liegen. Für achsensymmetrische Analysen müssen die Flächen außerdem rechts von der Y-Achse liegen. Ein gelbes Dreieck mit weißem Ausrufezeichen neben dem Bauteilnamen weist auf mögliche Geometrieprobleme hin, die eine weitere Untersuchung und Reparatur erfordern können (in der CAD-Software vor dem Import in Solvix).
  3. Bei CAD- und STL-Geometrie die Vernetzung vorbereiten ( Mesh > Mesh Setup Item > Create ) und ein Netz erzeugen ( Mesh > Create Mesh ). Das Netz kann auch ohne Vernetzungselemente erzeugt werden – dann gelten die Standardeinstellungen.
  4. Nach erfolgreicher Netzerzeugung zum Bereich FEM Model des Modellbaums wechseln.
  5. Material für die Analyse definieren ( Materials > Create ), geeignete Materialverhalten hinzufügen: Elastizität, Dichte (für Modalanalysen oder bei Verwendung von Schwerkraft- oder Zentrifugallasten), Plastizität (zur Berücksichtigung bleibender Verformungen), Thermisch oder Verschleiß durch Gleiten.
  6. Mit dem zuvor definierten Material einen neuen Abschnitt anlegen ( Section > Create ). Der Abschnittstyp kann Solid (für 3D- oder 2D-Volumenelemente), Shell (für Schalenelemente) oder Membrane (für Membranelemente) sein. Bei Verwendung von Schalen-, Membran- oder Scheiben-/Verzerrungselementen muss außerdem die Dicke angegeben werden. Wählen Sie das Bauteil aus, dem der Abschnitt zugewiesen werden soll.
  7. Einen neuen Analyseschritt anlegen. In den meisten Fällen genügen die Standardeinstellungen des Schritts.
  8. Optional: Zwangsbedingungen anlegen ( Constraints > Create ), Kontakt definieren (Container Contact aufklappen, Surface Interactions > Create wählen und dann Contact pairs > Create wählen), Anfangsbedingungen ( Initial condition > Create ), definierte Felder ( Define fields > Create ) und/oder Amplituden ( Amplitude > Create ).
  9. Randbedingungen ( BCs > Create ) und Lasten ( Loads > Create ) definieren. Es gibt mehrere Typen, die auf verschiedene Weise auf das Modell angewendet werden können (wird später erläutert).
  10. Die Analyse starten ( Analysis-1 > Run ); nach dem Abschluss lassen sich die Ergebnisse anzeigen ( Analysis-1 > Results ). Die verschiedenen Post-Processing-Optionen werden später erläutert.

In Solvix lässt sich mit Knoten- und Elementmengen sowie mit Flächen arbeiten. Sie können angelegt werden, bevor eine Randbedingung, Last, Zwangsbedingung oder ein Kontakt erstellt wird, und dann bei der Definition des gewählten Elements referenziert werden. Üblicherweise ist es jedoch vorzuziehen, Elemente ohne vorheriges Anlegen von Mengen/Flächen hinzuzufügen. In diesem Fall erlaubt das Auswahlwerkzeug im Elementfenster dem Benutzer, Entitäten je nach Elementtyp anhand der Geometrie oder des Netzes auszuwählen.

Es gibt zwei grundlegende Arbeitsweisen in Solvix: Optionen aus den Menüs verwenden (Menüleiste und obere Symbolleiste) oder sie im Modellbaum auswählen. Einige weiterführende Optionen sind nur über die Menüleiste erreichbar.

Ansichtssteuerung in Solvix:

  • Zoomen: Mausrad;
  • Modell drehen: mittlere Maustaste oder Pfeiltasten;
  • Verschieben (Modell bewegen): Umschalt + mittlere Maustaste.

Ein Druck mit der mittleren Maustaste auf eine beliebige Stelle des Bauteils verschiebt diese Stelle in die Bildschirmmitte und legt sie als Drehzentrum fest.

Zur Auswahl die linke Maustaste verwenden (zum Ziehen eines Auswahlrahmens die Maus ziehen – es werden nur Objekte ausgewählt, die vollständig innerhalb des Rahmens liegen). Umschalt beim Auswählen fügt Entitäten hinzu, Strg entfernt sie.

Über jeder der drei Hauptregisterkarten befindet sich eine Suchleiste. Sie kann zum Filtern des Geometrie-, des FEM-Modell- und des Ergebnisbaums verwendet werden.

Eingabefelder mit Einheiten unterstützen die Umrechnung. Der Benutzer kann einen Wert eingeben, die angezeigte Standardeinheit ändern (zum Beispiel MPa in GPa) und nach Drücken der Eingabetaste wird die Umrechnung durchgeführt; Solvix zeigt den Wert in Standardeinheiten an.

Im Fehlerfall (wenn Solvix unerwartet geschlossen wird) wird der Benutzer gefragt, ob eine Absturz-Wiederherstellungsdatei verwendet werden soll, um die vorherige Sitzung wiederherzustellen.

Solvix unterstützt das Post-Processing von Analysen mit einigen Funktionen, die für das Pre-Processing in der grafischen Oberfläche noch nicht umgesetzt sind – namentlich lassen sich Sensitivitätsanalysen und Simulationen mit Zustandsvariablen (SDV) visualisieren.

Abbildung 3: Hauptsymbolleiste von Solvix

Menü Datei

Das Menü Datei enthält die folgenden Optionen:

  • Neu ( Strg + N ) – ein neues Modell anlegen. Der Modellraum kann 3D, 2D ebener Spannungszustand, 2D ebener Verzerrungszustand oder 2D achsensymmetrisch sein. Die folgenden Einheitensysteme sind verfügbar (abgeleitete Einheiten werden bei Auswahl eines Einheitensystems angezeigt):
    • Einheitenlos,
    • m, kg, s, °C – SI-Standardeinheiten,
    • mm, t, s, °C – für den Maschinenbau typischer Einheitensatz,
    • m, t, s, °C,
    • in, lbf · s 2/in, s, °F – imperiale Einheiten.
  • Öffnen ( Strg + O ) – ein zuvor erstelltes Modell (.svx), einen Verlauf (.svxh), Solvix-Ergebnisse (.frd) oder OpenFOAM-Dateien (.foam) öffnen
  • Zuletzt geöffnet – eines der zuletzt verwendeten Modelle öffnen oder die Liste der zuletzt verwendeten Dateien leeren.
  • Verlaufsdateien ausführen – eine Datei .svxh ausführen.
  • Importieren ( Strg + I ) – CAD-Geometrie, Netz oder Modell in einem der folgenden Formate importieren:
    • STEP: .stp und .step (in den meisten Fällen empfohlen),
    • IGES: .igs und .iges,
    • B-rep: .brep,
    • Stereolithografie: .stl,
    • Universal: .unv,
    • Netgen: .vol,
    • Abaqus/Solvix-Eingabedateien: .inp,
    • Mmg-Netz: .mesh.
  • Speichern ( Strg + S ) – Änderungen am aktuellen Modell speichern.
  • Speichern unter – das Modell als Datei .svx mit einem vorgegebenen Namen speichern.
  • Exportieren – Bauteil/Modell in einem der folgenden Formate exportieren:
    • STEP: .stp,
    • B-rep: .brep,
    • Stereolithografie: .stl,
    • Solvix-Eingabedatei: .inp,
    • Abaqus-Eingabedatei (experimentell): .inp,
    • Mmg-Netz: .mesh,
    • Verformtes Netz: .inp (berücksichtigt den aktuellen Verformungsmaßstab; exportiert Volumenelemente, wenn die Ausgabe für die Analyse mit Schalenelementen auf 3D eingestellt ist),
    • Verformte Visualisierung: .stl (berücksichtigt den aktuellen Verformungsmaßstab).
  • Aktuelles Ergebnis schließen – das aktuell angezeigte Ergebnis aus dem Post-Processing-Teil des Modellbaums schließen (Speichern des Modells .svx ohne Ergebnisse verkleinert die Datei).
  • Alle Ergebnisse schließen – alle Ergebnisse aus dem Post-Processing-Teil des Modellbaums schließen (Speichern des Modells svx ohne Ergebnisse verkleinert die Datei).
  • Beenden ( Strg + F4 ) – Solvix schließen (der Benutzer wird gefragt, ob das Modell zuerst gespeichert werden soll).

Menü Bearbeiten

Das Menü Bearbeiten enthält die folgenden Optionen:

  • Rückgängig – die letzte Aktion rückgängig machen.
  • Wiederholen – die zuvor rückgängig gemachte Aktion wiederholen.
  • Verlauf bearbeiten – den Verlaufseditor öffnen. Dort lässt sich der Verlauf der ausgeführten Operationen ansehen und ausgewählte Befehlseinträge löschen, indem man die erste Spalte der Zeile auswählt und die Entf-Taste drückt. Der gesamte Verlauf kann mit der Schaltfläche Clear All gelöscht werden. Änderungen am Verlauf wirken sich auf die Funktion Regenerate aus, daher ist vorsichtig vorzugehen. Das Leeren eines sehr langen Verlaufs kann die Reaktionsfähigkeit von Solvix verbessern, da der Verlauf nach jedem neuen Befehl in eine Datei geschrieben wird (also nach jedem Element, das dem Modell hinzugefügt wird).
  • Modell neu aufbauen – das Modell neu aufbauen (nur Modellbefehle – Befehle für Analyse und Post-Processing werden nicht neu ausgeführt).
  • Modell mit anderen Dateien neu aufbauen – die Geometrie des Modells durch eine ähnliche aus einer anderen Datei ersetzen, sodass das Modell nicht neu definiert werden muss (nur Modellbefehle – Befehle für Analyse und Post-Processing werden nicht neu ausgeführt).
  • Modell mit erneuter Vernetzung neu aufbauen – das Modell neu vernetzen und dabei alle Knotenmengen, Elementmengen und Flächendaten beibehalten, die über netzbasierte Auswahlen definiert wurden – das Modell kann neu vernetzt werden, ohne die geometriebasierten Auswahlen neu definieren zu müssen (nur Modellbefehle – Befehle für Analyse und Post-Processing werden nicht neu ausgeführt).
  • Alles neu aufbauen – das Modell neu aufbauen (alle Befehle).
  • Alles mit anderen Dateien neu aufbauen – die Geometrie des Modells durch eine ähnliche aus einer anderen Datei ersetzen, sodass das Modell nicht neu definiert werden muss (alle Befehle).
  • Alles mit erneuter Vernetzung neu aufbauen – das Modell neu vernetzen und dabei alle Knotenmengen, Elementmengen und Flächendaten beibehalten, die über netzbasierte Auswahlen definiert wurden – das Modell kann neu vernetzt werden, ohne die geometriebasierten Auswahlen neu definieren zu müssen (alle Befehle).

Menü Ansicht

Das Menü Ansicht enthält die folgenden Optionen:

  • Standardansichten – eine der vordefinierten Ansichten anwenden:
    • Vorne oder hinten,
    • Oben oder unten,
    • Links oder rechts,
    • Normal, – Vertikal,
    • Isometrisch.
  • Zoom auf Auswahl – das Modell so zoomen, dass es ins Fenster passt.
  • Drahtmodell – eine Ansicht anwenden, die nur die Modellkanten zeigt.
  • Elementkanten anzeigen – eine Ansicht anwenden, die das Modell mit den Finite-Elemente-Kanten zeigt.
  • Modellkanten anzeigen – eine Ansicht anwenden, die das Modell und seine Elementkanten zeigt.
  • Keine Kanten – eine Ansicht ohne Kanten anwenden.
  • Schnittansicht – das Modell mit einer durch einen Punkt und eine Normale definierten Ebene schneiden oder die Schnittansicht deaktivieren (diese Option ist auch im Post-Processing verfügbar) – Achtung: Bei Verwendung der Schnittansicht im Register Geometry erscheinen selbst Volumenbauteile hohl.
  • Explosionsansicht – Bauteile einer Baugruppe in Explosionsdarstellung zeigen – 2 Methoden verfügbar:
    • Standard: Richtung der Explosionsansicht, Vergrößerung, Maßstab,
    • Mittelpunkt: X-/Y-/Z-Koordinaten, Richtung der Explosionsansicht, Vergrößerung, Maßstab.
  • Alle anzeigen – alle Bauteile des Modells anzeigen (einblenden).
  • Alle ausblenden – alle Bauteile des Modells ausblenden.
  • Sichtbare Bauteile invertieren – die Sichtbarkeit der Bauteile umkehren.
  • Unverformt – das unverformte Modell in den Ergebnissen anzeigen.
  • Verformt – das verformte Modell in den Ergebnissen anzeigen.
  • Verformt mit Farbkonturen – das verformte Modell mit Konturdiagramm in den Ergebnissen anzeigen.
  • Verformt & Farbe & Drahtmodell – das verformte Modell mit Konturdiagramm und Drahtmodell des unverformten Modells in den Ergebnissen anzeigen.
  • Verformt & Farbe & Volumen – das verformte Modell mit Konturdiagramm und Volumendarstellung des unverformten Modells in den Ergebnissen anzeigen.
  • Farbannotationen – Farben verwenden, um Objekte des Modells nach verschiedenen Kriterien zu unterscheiden: Flächenausrichtungen, Bauteile, Materialien, Abschnitte, Abschnittsdicken, alle Symbole, Referenzpunkte, Zwangsbedingungen, Kontaktpaare, Randbedingungen, Lasten.

Abbildung 4: Symbolleiste Datei und Ansicht


Ausgewählte Optionen der Menüs Datei und Ansicht sind direkt über eine Symbolleiste erreichbar (Abbildung 4). Diese Symbolleiste enthält außerdem zwei Schaltflächen für Abfragen und Annotationen, auf die später eingegangen wird.

Menü Extras

Das Menü Extras enthält die folgenden Optionen:

  • Einstellungen – um alle Einstellungen in einem der unten aufgeführten Registerkarten auf die Standardwerte zurückzusetzen, mit der rechten Maustaste in den leeren Bereich klicken und Reset all wählen
  • Allgemein
    • Letzte Datei öffnen, Name der letzten Datei.
    • Ergebnisse in .svx-Dateien speichern.
    • .svx-Dateien komprimieren: Keine Komprimierung, Am schnellsten, Optimal.
    • Standard-Einheitensystem.
    • Netz importieren → Kantenwinkel.
  • Grafik
    • Hintergrund: Typ, obere Farbe, untere Farbe.
    • Geometrie: CAD-Abweichung.
    • Beleuchtung: Umgebungsanteil, Diffusanteil.
    • Glättung: Punktglättung, Linienglättung.
    • Widgets: Sichtbarkeit des Koordinatensystems, Sichtbarkeit des Maßstabs-Widgets.
  • Standardfarben
    • Flächenausrichtung: Farbe der Vorderseite, Farbe der Rückseite.
    • Allgemein.
  • Annotationen
    • Gestaltung: Hintergrundtyp, Rahmenrechteck zeichnen, Zahlenformat, Anzahl signifikanter Stellen
    • Kanten-/Flächenannotation: ID von Kante/Fläche anzeigen, Typ von Kante/Fläche anzeigen, Größe von Kante/Fläche anzeigen, Maximalwert anzeigen, Minimalwert anzeigen, Summenwert anzeigen, Mittelwert anzeigen
    • Knotenannotation: Knoten-ID anzeigen, Koordinaten anzeigen
    • Bauteilannotation: Bauteilnamen anzeigen, Bauteil-ID anzeigen, Bauteiltyp anzeigen, Anzahl der Elemente anzeigen, Anzahl der Knoten anzeigen
  • Vernetzung – Standardeinstellungen für die Vernetzung
    • Netzgröße: Definition der Netzgröße, Maximaler Elementfaktor, Minimaler Elementfaktor, Abstufung,
    • Elemente pro Kante, Elemente pro Krümmung, Hausdorff-Faktor,
    • Netzoptimierung: Optimierungsschritte 2D, Optimierungsschritte 3D,
    • Netztyp: Zweite Ordnung, Seitenmittenknoten auf Geometrie, Viereckbetontes Netz,
    • Netzoperationen: Verbundnetz aufteilen, Verbundbauteile zusammenführen, Modellkanten beibehalten.
  • Pre-Processing
    • Farbskala: Hintergrundtyp, Rahmenrechteck zeichnen.
    • Auswahl: Standard-Auswahlmodus für Geometrie, Farbe der primären/sekundären/Maus-Hervorhebung.
    • Symbole: Farbe von Zwangsbedingung/Randbedingung/Last, Symbolgröße, Knotensymbolgröße, Symbolkanten zeichnen.
  • Löser
    • Löser: Arbeitsverzeichnis, .svx-Ordner als Arbeitsverzeichnis verwenden, Programmdatei, Standardlöser.
    • Parallelisierung: Anzahl der Prozessoren, Umgebungsvariablen.
    • Experimentell: Pyramidenelemente umwandeln in (Zusammengeklappte Keile/Zusammengeklappte Hexaeder)
  • Post-Processing
    • Unverformtes Modell
      • Unverformtes Modell zeichnen: Keine/Drahtmodellkörper/Volumenkörper,
      • Farbe des unverformten Modells.
    • Grenzwerte
      • Position des Minimalwerts anzeigen: Ja/Nein,
      • Position des Maximalwerts anzeigen: Ja/Nein.
    • Verlaufsausgabe
      • Maximale Anzahl von Verlaufsausgabe-Einträgen.
  • Legende
    • Einstellungen des Farbspektrums
      • Typ des Farbspektrums: Kalt-warm, Regenbogen, Regenbogen entsättigt, Warm, Kalt, Cividis, Viridis, Plasma, Schwarzkörper, Inferno, KindImann, Graustufen,
      • Helligkeit,
      • Farben umkehren: Ja/Nein,
      • Anzahl diskreter Farben – im Bereich von 2-24.
    • Werte des Farbspektrums
      • Zahlenformat: Wissenschaftlich/Allgemein,
      • Anzahl signifikanter Stellen – im Bereich von 2-8, · Typ des Min-/Max-Grenzwerts: Automatisch/Manuell.
    • Gestaltung
      • Hintergrundtyp: Keine/Weiß,
      • Rahmenrechteck zeichnen: Ja/Nein.
  • Statusblock
    • Gestaltung
      • Sichtbarkeit des Statusblocks: Ja/Nein,
      • Hintergrundtyp: Keine/Weiß,
      • Rahmenrechteck zeichnen: Ein/Aus.
  • Parameter
    • Name
    • Wert/Gleichung
    • Ergibt
  • Abfrage
    • Knotenpunkt/Knoten – ID und Koordinaten des Knotenpunkts/Knotens sowie den Wert der aktuell angezeigten Feldausgabe an diesem Knoten prüfen (in Results).
    • Facette/Element – die ID der Facette/des Elements prüfen.
    • Kante – die ID der Kante und deren Länge sowie Maximal-, Minimal- und Gesamtwert der aktuell angezeigten Feldausgabe entlang dieser Kante prüfen (in Results).
    • Fläche – die ID der Fläche und deren Flächeninhalt sowie Maximal-, Minimal- und Gesamtwert der aktuell angezeigten Feldausgabe auf dieser Fläche prüfen (in Results)
    • Bauteil – Bauteilinformationen prüfen (Name, ID, Typ, Anzahl der Elemente und Knoten).
    • Baugruppe – Anzahl der Bauteile, Elemente und Knoten prüfen.
    • Größe der Begrenzungsbox – die Größe der Begrenzungsbox des Modells prüfen.
    • Abstand – den Abstand zwischen zwei Knoten messen.
    • Winkel – den Winkel über drei Punkte messen.
    • Kreis – den Radius des Kreises durch drei ausgewählte Punkte messen.
  • Suchen
    • Objekttyp: Knotenpunkt/Knoten, Facette/Element, Kante, Fläche, Bauteil.
    • Daten: Annotation hinzufügen, Objekt-ID.

Derzeit zeigen die meisten über das Menü Abfrage erstellten Annotationen die Ausgabe nicht nur im Meldungsbereich am unteren Rand des Solvix-Fensters an, sondern auch als Beschriftungen am Modell. Ein Rechtsklick darauf zeigt die Optionen Edit (angezeigten Inhalt manuell ändern), Reset und Delete (Löschen). Auf diese Weise ist auch das Einstellungsmenü erreichbar, in dem die Annotationen weiter angepasst werden können. Ein Klick auf die Schaltfläche Clear am unteren Rand des Fensters Abfrage löscht alle sichtbaren Annotationen (es können mehrere Annotationen unterschiedlicher Art gleichzeitig angezeigt werden). Auf der Symbolleiste Datei und Ansicht gibt es außerdem die Schaltfläche Remove annotations (Abbildung 6). Daneben befindet sich die Schaltfläche Query, eine Verknüpfung für Tools Abfrage . Annotationen werden zudem in .svx-Dateien gespeichert.

Das Werkzeug Suchen dient dazu, geometrische und netzbezogene Entitäten mit einer bestimmten ID zu finden (hervorzuheben). Es ist zum Beispiel nützlich, wenn Knoten oder Elemente gesucht werden, die der Löser als problematisch meldet.

Einheitenlose Parameter können definiert und dann in Gleichungen für die Definition von Referenzpunkten, Materialien, Abschnitten, Zwangsbedingungen, Lasten und Randbedingungen verwendet werden. Zum Hinzufügen einer Gleichung muss das Eingabefeld mit dem Gleichheitszeichen = beginnen und die Einheit aus dem Feld entfernt werden. Die Gleichungen nutzen die Open-Source-Bibliothek Ncalc, deren Funktionen daher unterstützt werden.