Manual / Capítulo 2 – Flujo de trabajo

Capítulo 2 – Flujo de trabajo

Las tres pestañas del árbol del modelo, el orden general de trabajo y el contenido de cada menú superior.

MANUAL CH. 34 SECCIONES17 MIN DE LECTURAACTUALIZADO 2025-10-20

En Solvix, tres pestañas del árbol del modelo determinan el flujo de trabajo en este programa:

  • Geometría – edición de la geometría y generación de la malla,
  • Modelo FEM – configuración del análisis (preprocesamiento),
  • Resultados – posprocesamiento.

Cada pestaña también activa los menús correspondientes en la barra de herramientas superior.

Figura 2: Pestañas del modelo de Solvix

Los pasos generales que deben seguirse al trabajar en Solvix se enumeran a continuación:

  1. Cree un modelo nuevo ( File > New ) y seleccione un espacio de modelo y un sistema de unidades.
  2. Importe la geometría o la malla de CAD/STL para el análisis ( File > Import ). En los análisis 2D, las piezas deben importarse como caras situadas completamente en el plano XY. Además, en los análisis axisimétricos, las caras que representan las piezas deben situarse a la derecha del eje Y. Un triángulo amarillo con signo de exclamación blanco junto al nombre de la pieza indica posibles problemas de geometría que pueden requerir un estudio y una reparación posteriores (en el programa de CAD antes de importar a Solvix).
  3. Para la geometría de CAD y STL, prepare la configuración de la malla ( Mesh > Mesh Setup Item > Create ) y genere una malla ( Mesh > Create Mesh ). La malla también puede generarse sin elementos de configuración; en ese caso se utilizarán los ajustes predeterminados.
  4. Cuando la malla se haya creado correctamente, pase a la parte Modelo FEM del árbol del modelo.
  5. Defina el material para el análisis ( Materials > Create ) y añada los comportamientos de material adecuados: Elasticity, Density (para realizar un análisis modal o utilizar cargas de gravedad o centrífugas), Plasticity (para tener en cuenta las deformaciones permanentes), Thermal o Slip wear.
  6. Cree una sección nueva con el material definido anteriormente ( Section > Create ). El tipo de sección puede ser Solid (para utilizar elementos sólidos 3D o 2D), Shell (para utilizar elementos de lámina) o Membrane (para utilizar elementos de membrana). También debe especificarse el espesor si se utilizan elementos de lámina, de membrana o de tensión/deformación plana. Seleccione la pieza a la que se asignará la sección.
  7. Cree un nuevo paso de análisis. Los ajustes predeterminados del paso son suficientes en la mayoría de los casos.
  8. Opcional: cree restricciones ( Constraints > Create ), defina el contacto (expanda el contenedor Contact, seleccione Surface Interactions > Create y, a continuación, Contact pairs > Create ), las condiciones iniciales ( Initial condition > Create ), los campos definidos ( Define fields > Create ) y/o las amplitudes ( Amplitude > Create ).
  9. Defina las condiciones de contorno ( BCs > Create ) y las cargas ( Loads > Create ). Existen varios tipos disponibles y pueden aplicarse al modelo de distintas maneras (se explican más adelante).
  10. Envíe el análisis a ejecución ( Analysis-1 > Run ); cuando termine, podrá consultar los resultados ( Analysis-1 > Results ). Las distintas opciones de posprocesamiento se explican más adelante.

En Solvix es posible trabajar con conjuntos de nodos y de elementos, así como con superficies. Pueden definirse antes de crear cualquier condición de contorno, carga, restricción o contacto y luego referenciarse en la definición de la función seleccionada. Sin embargo, normalmente es preferible añadir funciones sin crear antes conjuntos o superficies. En esos casos, la herramienta de selección de la ventana de la función permite al usuario elegir entidades según la geometría o la malla, dependiendo del tipo de función.

Existen dos formas principales de trabajar en Solvix: utilizar las opciones disponibles en los menús (barra de menús y barra de herramientas superior) o seleccionarlas en el árbol del modelo. Algunas opciones más avanzadas solo pueden accederse desde la barra de menús.

Controles de vista en Solvix:

  • Zoom: rueda del ratón;
  • Rotar el modelo: botón central del ratón o flechas del teclado;
  • Desplazar (mover el modelo): Shift + botón central del ratón.

Al pulsar el botón central del ratón en cualquier punto de la pieza, ese punto se desplaza al centro de la pantalla y se establece como centro de rotación.

Para seleccionar, utilice el botón izquierdo del ratón (arrastre el ratón para usar el cuadro de selección; solo se seleccionan los elementos completamente dentro del cuadro). Al mantener pulsada la tecla Shift la selección añade entidades, mientras que con Ctrl se eliminan.

En la parte superior de cada una de las tres pestañas principales hay una barra de búsqueda. Puede utilizarse para filtrar los árboles de geometría, de modelo FEM y de resultados.

Los campos de entrada que utilizan unidades admiten su conversión. El usuario puede introducir un valor, modificar la unidad predeterminada mostrada (por ejemplo, cambiar MPa por GPa) y la conversión se realizará al pulsar Intro; Solvix mostrará el valor en las unidades predeterminadas.

En caso de fallo (cuando Solvix se cierra inesperadamente), se pregunta al usuario si desea utilizar un archivo de recuperación de errores para regenerar la sesión anterior.

Solvix admite el posprocesamiento de análisis con algunas funciones que aún no están implementadas para el preprocesamiento en la interfaz gráfica; en concreto, pueden visualizarse los análisis de sensibilidad y las simulaciones con variables de estado (SDV).

Figura 3: Barra de herramientas principal de Solvix

Menú File

El menú File contiene las siguientes opciones:

  • New ( Ctrl + N ): crea un modelo nuevo. El espacio de modelo puede ser 3D, 2D Plane Stress, 2D Plane Strain o 2D Axisymmetric. Están disponibles los siguientes sistemas de unidades (las unidades derivadas se enumeran al seleccionar un sistema de unidades):
    • Sin unidades,
    • m, kg, s, °C: unidades SI estándar,
    • mm, ton, s, °C: conjunto de unidades típico de la ingeniería mecánica,
    • m, ton, s, °C,
    • in, lbf · s 2/in, s, °F: unidades imperiales.
  • Open ( Ctrl + O ): abre un modelo creado previamente (.svx), un historial (.svxh), resultados de Solvix (.frd) o archivos de OpenFOAM (.foam)
  • Open Recent: abre uno de los modelos usados recientemente o borra la lista de archivos recientes.
  • Run History Files: ejecuta un archivo .svxh.
  • Import ( Ctrl + I ): importa geometría de CAD, malla o modelo guardado en uno de los siguientes formatos:
    • STEP: .stp y .step (recomendado en la mayoría de los casos),
    • IGES: .igs y .iges,
    • B-rep: .brep,
    • Estereolitografía: .stl,
    • Universal: .unv,
    • Netgen: .vol,
    • Archivos de entrada de Abaqus/Solvix: .inp,
    • Malla de Mmg: .mesh.
  • Save ( Ctrl + S ): guarda los cambios en el modelo actual.
  • Save As: guarda el modelo como archivo .svx con un nombre determinado.
  • Export: exporta la pieza/el modelo en uno de los siguientes formatos:
    • STEP: .stp,
    • B-rep: .brep,
    • Estereolitografía: .stl,
    • Archivo de entrada de Solvix: .inp,
    • Archivo de entrada de Abaqus (experimental): .inp,
    • Malla de Mmg: .mesh,
    • Malla deformada: .inp (respeta el factor de escala de deformación actual; exporta elementos sólidos si la salida se establece en 3D para el análisis con elementos de lámina),
    • Visualización deformada: .stl (respeta el factor de escala de deformación actual).
  • Close Current Result: cierra los resultados mostrados actualmente en la parte de posprocesamiento del árbol del modelo (guardar el modelo .svx sin los resultados reduce el tamaño del archivo).
  • Close All Results: cierra todos los resultados de la parte de posprocesamiento del árbol del modelo (guardar el modelo svx sin los resultados reduce el tamaño del archivo).
  • Exit ( Ctrl + F4 ): cierra Solvix (antes se pregunta al usuario si desea guardar el modelo).

Menú Edit

El menú Edit contiene las siguientes opciones:

  • Undo: deshace la última acción.
  • Redo: rehace la acción deshecha anteriormente.
  • Edit History: abre el editor del historial, que permite ver el historial de operaciones realizadas y eliminar las entradas de comandos seleccionadas eligiendo la primera columna de la fila y pulsando la tecla Supr. Todo el historial puede eliminarse con el botón Clear All. Modificar el historial cambia la funcionalidad Regenerate, por lo que debe usarse con precaución. Borrar un historial muy largo puede mejorar la capacidad de respuesta de Solvix, ya que el historial se guarda en un archivo después de añadir cada nuevo comando (es decir, después de añadir cada función al modelo).
  • Regenerate Model: regenera el modelo (solo los comandos del modelo; los comandos de análisis y posprocesamiento no se regeneran).
  • Regenerate Model Using Other Files: sustituye la geometría del modelo por otra similar de otro archivo, de modo que no sea necesario volver a definir el modelo (solo los comandos del modelo; los comandos de análisis y posprocesamiento no se regeneran).
  • Regenerate Model With Re-meshing: vuelve a generar la malla del modelo conservando todos los conjuntos de nodos, conjuntos de elementos y datos de superficies definidos mediante selecciones basadas en la malla; el modelo puede volver a mallarse sin necesidad de redefinir las selecciones basadas en la geometría (solo los comandos del modelo; los comandos de análisis y posprocesamiento no se regeneran).
  • Regenerate All: regenera el modelo (todos los comandos).
  • Regenerate All Using Other Files: sustituye la geometría del modelo por otra similar de otro archivo, de modo que no sea necesario volver a definir el modelo (todos los comandos).
  • Regenerate All With Re-meshing: vuelve a generar la malla del modelo conservando todos los conjuntos de nodos, conjuntos de elementos y datos de superficies definidos mediante selecciones basadas en la malla; el modelo puede volver a mallarse sin necesidad de redefinir las selecciones basadas en la geometría (todos los comandos).

Menú View

El menú View contiene las siguientes opciones:

  • Standard Views: aplica una de las vistas predefinidas:
    • Front o Back,
    • Top o Bottom,
    • Left o Right,
    • Normal, – Vertical,
    • Isometric.
  • Zoom to Fit: aplica un zoom de modo que el modelo quepa en la ventana.
  • Wireframe: aplica una vista que muestra solo los bordes del modelo.
  • Show Element Edges: aplica una vista que muestra el modelo con los bordes de los elementos finitos.
  • Show Model Edges: aplica una vista que muestra el modelo y sus bordes de función.
  • No Edges: aplica una vista que muestra el modelo sin bordes.
  • Section View: corta el modelo mediante un plano definido por un punto y una normal, o desactiva la vista de sección (esta opción también puede usarse en el posprocesamiento); advertencia: incluso las piezas sólidas aparecen huecas cuando se utiliza la vista de sección en la pestaña Geometry.
  • Exploded View: muestra las piezas del ensamblaje en una vista explosionada; hay 2 métodos disponibles:
    • Default: dirección de la vista explosionada, Magnification, Scale factor,
    • Center point: coordenadas X/Y/Z, dirección de la vista explosionada, Magnification, Scale factor.
  • Show All: muestra (hace visibles) todas las piezas del modelo.
  • Hide All: oculta todas las piezas del modelo.
  • Invert Visible Parts: invierte la visibilidad de las piezas.
  • Undeformed: muestra el modelo no deformado en los resultados.
  • Deformed: muestra el modelo deformado en los resultados.
  • Deformed With Color Contours: muestra el modelo deformado con un gráfico de contornos en los resultados.
  • Deformed & Color & Wireframe: muestra el modelo deformado con un gráfico de contornos y la representación de estructura alámbrica del modelo no deformado en los resultados.
  • Deformed & Color & Solid: muestra el modelo deformado con un gráfico de contornos y la representación sólida del modelo no deformado en los resultados.
  • Color Annotations: utiliza colores para distinguir elementos del modelo según distintos criterios: orientaciones de las caras, piezas, materiales, secciones, espesores de sección, todos los símbolos, puntos de referencia, restricciones, pares de contacto, condiciones de contorno, cargas.

Figura 4: Barra de herramientas File y View


Las opciones seleccionadas de los menús File y View pueden accederse directamente mediante un menú de la barra de herramientas que se muestra en la Figura 4. Esta barra de herramientas también contiene dos botones para consultas y anotaciones, que se explican más adelante.

Menú Tools

El menú Tools contiene las siguientes opciones:

  • Settings: para restablecer todos los ajustes de cualquiera de las pestañas enumeradas a continuación a sus valores predeterminados, haga clic con el botón derecho en un espacio vacío y seleccione Reset all
  • General
    • Abrir el último archivo, nombre del último archivo.
    • Guardar los resultados en archivos .svx.
    • Comprimir los archivos .svx: No compression, Fastest, Optimal.
    • Sistema de unidades predeterminado.
    • Importar malla → Edge angle.
  • Graphics
    • Background: Type, Top color, Bottom color.
    • Geometry: CAD deflection.
    • Lighting: Ambient component, Diffuse component.
    • Smoothing: Point smoothing, Line smoothing.
    • Widgets: Coordinate system visibility, Scale widget visibility.
  • Default Colors
    • Face orientation: Front face color, Back face color.
    • General.
  • Annotations
    • Design: Background type, Draw a border rectangle, Number format, Number of significant digits
    • Edge/Surface annotation: Show edge/surface id, Show edge/surface type, Show edge/surface size, Show maximum value, Show minimum value, Show sum value, Show average value
    • Node annotation: Show node id, Show coordinates
    • Part annotation: Show part name, Show part id, Show part type, Show number of elements, Show number of nodes
  • Part annotation: Show part name, Show part id, Show part type, Show number of elements, Show number of nodes
    • Meshing: ajustes predeterminados para el mallado
    • Mesh size: Mesh size definition, Max element factor, Min element factor, Grading,
    • Elements per edge, Elements per curvature, Hausdorff factor,
    • Mesh optimization: Optimize steps 2D, Optimize steps 3D,
    • Mesh type: Second order, Mid-side nodes on geometry, Quad-dominated mesh,
  • Mesh operations: Split compound mesh, Merge compound parts, Keep model edges.
    • Pre-processing
    • Color bar: Background type, Draw a border rectangle.
    • Selection: Default geometry selection mode, Primary/secondary/mouse highlight color.
  • Symbols: Constraint/Boundary condition/Load color, Symbol size, Node symbol size, Draw symbol edges.
    • Solver
    • Solver: Work directory, Use .svx folder as work directory, Executable, Default solver.
    • Parallelization: Number of processors, Environment variables.
  • Experimental: Convert pyramid elements to (Collapsed wedges/Collapsed hexahedrons)
    • Post-processing
      • Mostrar el modelo no deformado: None/Wireframe body/Solid body,
      • Color del modelo no deformado.
    • Limit values
      • Show min value location: Yes/No,
      • Show max value location: Yes/No.
    • History output
      • Max history output entries.
  • Legend
    • Color spectrum settings
      • Color spectrum type: Cool-warm, Rainbow, Rainbow desaturated, Warm, Cool, Cividis, Viridis, Plasma, Black body, Inferno, KindImann, Grayscale,
      • Brightness,
      • Reverse colors: Yes/No,
      • Number of discrete colors: en el intervalo de 2 a 24.
    • Color spectrum values
      • Number format: Scientific/General,
      • Number of significant digits: en el intervalo de 2 a 8, · Min/Max limit type: Automatic/Manual.
    • Design
      • Background type: None/White,
      • Draw a border rectangle: Yes/No.
  • Status Block
    • Design
      • Status block visibility: Yes/No,
      • Background type: None/White,
      • Draw a border rectangle: On/Off.
  • Parameters
    • Nombre
    • Valor/Ecuación
    • Se evalúa como
  • Query
    • Vertex/Node: comprueba el ID del vértice/nodo, las coordenadas y el valor de la salida de campo mostrada actualmente en este nodo (en Results).
    • Facet/Element: comprueba el ID de la faceta/elemento.
    • Edge: comprueba el ID del borde y su longitud, así como el valor máximo, mínimo y total de la salida de campo mostrada actualmente a lo largo de este borde (en Results).
    • Surface: comprueba el ID de la superficie y su área, así como el valor máximo, mínimo y total de la salida de campo mostrada actualmente en esta superficie (en Results)
    • Part: comprueba la información de la pieza (nombre, id, tipo, número de elementos y de nodos).
    • Assembly: comprueba el número de piezas, de elementos y de nodos.
    • Bounding box size: comprueba el tamaño de la caja envolvente del modelo.
    • Distance: mide la distancia entre dos nodos.
    • Angle: mide el ángulo utilizando tres puntos.
    • Circle: mide el radio del círculo que pasa por tres puntos seleccionados.
  • Find
    • Item type: Vertex/Node, Facet/Element, Edge, Surface, Part.
    • Data: Add annotation, Item id.

Actualmente, la mayoría de las anotaciones creadas con el menú Query muestran la salida no solo en el área de mensajes situada en la parte inferior de la ventana de Solvix, sino también en forma de etiquetas asociadas al modelo. Al hacer clic con el botón derecho sobre ellas se muestran las opciones para Editarlas (modificar manualmente el contenido mostrado), Restablecerlas y Eliminarlas. De este modo también es posible acceder al menú de ajustes donde pueden modificarse más las anotaciones. Al pulsar el botón Clear situado en la parte inferior de la ventana Query, se eliminan todas las anotaciones visibles (es posible mostrar varias anotaciones de distinto tipo a la vez). También hay un botón Remove annotations en la barra de herramientas File y View (Figura 6). Junto a él hay un botón Query, un acceso directo a Tools Query . Además, las anotaciones se guardan en archivos .svx.

La herramienta Find puede utilizarse para localizar (resaltar) entidades geométricas y de malla con un ID especificado. Puede resultar útil, por ejemplo, al buscar nodos o elementos que el solucionador haya indicado como problemáticos.

Pueden definirse parámetros sin unidades y luego utilizarlos en ecuaciones para la definición de puntos de referencia, materiales, secciones, restricciones, cargas y condiciones de contorno. Para añadir una ecuación, debe comenzar el campo de entrada con el signo igual = y eliminar la unidad del campo. Las ecuaciones utilizan la biblioteca de código abierto Ncalc, por lo que se admiten sus funciones.