Manuale / Capitolo 2 – Flusso di lavoro

Capitolo 2 – Flusso di lavoro

Le tre schede dell'albero del modello, l'ordine di lavoro generale e il contenuto di ogni menu superiore.

MANUAL CH. 34 SEZIONI17 MIN DI LETTURAAGGIORNATO IL 2025-10-20

In Solvix, tre schede dell’albero del modello determinano il flusso di lavoro del software:

  • Geometry – modifica della geometria e generazione della mesh,
  • FEM Model – impostazione dell’analisi (pre-elaborazione),
  • Results – post-elaborazione.

Ogni scheda attiva inoltre i menu appropriati nella barra degli strumenti superiore.

Figura 2: Schede del modello di Solvix

I passaggi generali da seguire quando si lavora in Solvix sono elencati di seguito:

  1. Crei un nuovo modello ( File > New ) e selezioni uno spazio del modello e un sistema di unità di misura.
  2. Importi la geometria CAD/STL o la mesh per l’analisi ( File > Import ). Per le analisi 2D, le parti devono essere importate come facce giacenti interamente nel piano XY. Inoltre, per le analisi assialsimmetriche, le facce che rappresentano le parti devono trovarsi a destra dell’asse Y. Un triangolo giallo con punto esclamativo bianco accanto al nome della parte indica possibili problemi nella geometria che potrebbero richiedere ulteriori verifiche e correzioni (nel software CAD, prima di importare in Solvix).
  3. Per le geometrie CAD e STL, prepari le impostazioni della mesh ( Mesh > Mesh Setup Item > Create ) e generi la mesh ( Mesh > Create Mesh ). La mesh può essere generata anche senza voci di impostazione: verranno usate le impostazioni predefinite.
  4. Quando la mesh è stata creata correttamente, passi alla parte FEM Model dell’albero del modello.
  5. Definisca il materiale per l’analisi ( Materials > Create ) e aggiunga i comportamenti del materiale necessari: Elasticity, Density (per eseguire un’analisi modale o usare carichi gravitazionali o centrifughi), Plasticity (per tenere conto delle deformazioni permanenti), Thermal o Slip wear.
  6. Crei una nuova sezione con il materiale definito in precedenza ( Section > Create ). Il tipo di sezione può essere Solid (per usare elementi solidi 3D o 2D), Shell (per usare elementi shell) o Membrane (per usare elementi a membrana). Lo spessore deve essere specificato anche se si usano elementi shell, a membrana o in stato di tensione/deformazione piana. Selezioni la parte a cui assegnare la sezione.
  7. Crei un nuovo passo di analisi. Le impostazioni predefinite del passo sono sufficienti nella maggior parte dei casi.
  8. Facoltativo: crei vincoli ( Constraints > Create ), definisca il contatto (espanda il contenitore Contact, selezioni Surface Interactions > Create e poi Contact pairs > Create ), condizioni iniziali ( Initial condition > Create ), campi definiti ( Define fields > Create ) e/o ampiezze ( Amplitude > Create ).
  9. Definisca le condizioni al contorno ( BCs > Create ) e i carichi ( Loads > Create ). Sono disponibili diversi tipi, applicabili al modello in modi differenti (illustrati più avanti).
  10. Invii l’analisi ( Analysis-1 > Run ); al termine, potrà visualizzarne i risultati ( Analysis-1 > Results ). Le varie opzioni di post-elaborazione saranno illustrate più avanti.

In Solvix è possibile lavorare con insiemi di nodi e di elementi, oltre che con superfici. Tali entità possono essere definite prima di creare qualsiasi condizione al contorno, carico, vincolo o contatto e poi richiamate nella definizione della funzione selezionata. Di norma, però, è preferibile aggiungere le funzioni senza creare prima insiemi o superfici. In questi casi, lo strumento di selezione nella finestra della funzione consente all’utente di scegliere entità in base alla geometria o alla mesh, a seconda del tipo di funzione.

Esistono due modi principali per lavorare in Solvix: usare le opzioni disponibili nei menu (barra dei menu e barra degli strumenti superiore) oppure selezionarle nell’albero del modello. Alcune opzioni più avanzate sono accessibili solo dalla barra dei menu.

Controlli di visualizzazione in Solvix:

  • Zoom: rotellina del mouse;
  • Rotazione del modello: pulsante centrale del mouse o frecce della tastiera;
  • Panoramica (spostamento del modello): Maiusc + pulsante centrale del mouse.

Premendo il pulsante centrale del mouse in un punto qualsiasi della parte, quel punto viene portato al centro dello schermo e impostato come centro di rotazione.

Per la selezione usi il pulsante sinistro del mouse (trascini il mouse per usare il riquadro di selezione: vengono selezionate solo le entità interamente contenute nel riquadro). Tenendo premuto Maiusc durante la selezione si aggiungono entità, mentre tenendo premuto Ctrl le si rimuove.

Su ciascuna delle tre schede principali è disponibile una barra di ricerca. Può essere usata per filtrare gli alberi della geometria, del modello FEM e dei risultati.

I campi di input che utilizzano unità di misura supportano la conversione. L’utente può inserire un valore, modificare l’unità predefinita visualizzata (ad esempio cambiare MPa in GPa); la conversione avviene dopo aver premuto Invio e Solvix visualizzerà il valore nelle unità predefinite.

In caso di arresto anomalo (quando Solvix si chiude improvvisamente), all’utente viene chiesto se usare un file di recupero dopo l’arresto per rigenerare la sessione precedente.

Solvix supporta la post-elaborazione di analisi con alcune funzioni non ancora implementate per la pre-elaborazione nell’interfaccia grafica: in particolare, le analisi di sensibilità e le simulazioni che coinvolgono variabili di stato (SDV) possono essere visualizzate.

Figura 3: Barra degli strumenti principale di Solvix

Menu File

Il menu File contiene le seguenti opzioni:

  • New ( Ctrl + N ) – crea un nuovo modello. Lo spazio del modello può essere 3D, 2D Plane Stress, 2D Plane Strain o 2D Axisymmetric. Sono disponibili i seguenti sistemi di unità di misura (le unità derivate vengono elencate quando si seleziona un sistema):
    • Senza unità di misura,
    • m, kg, s, °C – unità SI standard,
    • mm, ton, s, °C – insieme di unità tipico dell’ingegneria meccanica,
    • m, ton, s, °C,
    • in, lbf · s 2/in, s, °F – unità imperiali.
  • Open ( Ctrl + O ) – apre un modello creato in precedenza (.svx), una cronologia (.svxh), risultati Solvix (.frd) o file OpenFOAM (.foam)
  • Open Recent – apre uno dei modelli usati di recente oppure cancella l’elenco dei file recenti.
  • Run History Files – esegue un file .svxh.
  • Import ( Ctrl + I ) – importa geometria CAD, mesh o un modello salvato in uno dei seguenti formati:
    • STEP: .stp e .step (consigliato nella maggior parte dei casi),
    • IGES: .igs e .iges,
    • B-rep: .brep,
    • Stereolitografia: .stl,
    • Universale: .unv,
    • Netgen: .vol,
    • File di input Abaqus/Solvix: .inp,
    • Mesh Mmg: .mesh.
  • Save ( Ctrl + S ) – salva le modifiche nel modello corrente.
  • Save As – salva il modello come file .svx con un nome specificato.
  • Export – esporta la parte o il modello in uno dei seguenti formati:
    • STEP: .stp,
    • B-rep: .brep,
    • Stereolitografia: .stl,
    • File di input Solvix: .inp,
    • File di input Abaqus (sperimentale): .inp,
    • Mesh Mmg: .mesh,
    • Mesh deformata: .inp (rispetta il fattore di scala della deformazione corrente; esporta elementi solidi se per l’analisi con elementi shell l’output è impostato su 3D),
    • Visualizzazione deformata: .stl (rispetta il fattore di scala della deformazione corrente).
  • Close Current Result – chiude i risultati attualmente visualizzati dalla parte di post-elaborazione dell’albero del modello (salvare il modello .svx senza i risultati riduce la dimensione del file).
  • Close All Results – chiude tutti i risultati della parte di post-elaborazione dell’albero del modello (salvare il modello svx senza i risultati riduce la dimensione del file).
  • Exit ( Ctrl + F4 ) – chiude Solvix (all’utente viene chiesto se salvare prima il modello).

Menu Edit

Il menu Edit contiene le seguenti opzioni:

  • Undo – annulla l’ultima azione.
  • Redo – ripristina l’azione annullata in precedenza.
  • Edit History – apre l’editor della cronologia, che consente di visualizzare la cronologia delle operazioni eseguite e di eliminare i comandi selezionati scegliendo la prima colonna della riga e premendo il tasto Canc. L’intera cronologia può essere eliminata con il pulsante Clear All. Modificare la cronologia modifica la funzionalità Regenerate, pertanto se ne consiglia un uso prudente. Cancellare una cronologia molto lunga può migliorare la reattività di Solvix, poiché la cronologia viene salvata in un file dopo ogni nuovo comando aggiunto (cioè dopo ogni funzione aggiunta al modello).
  • Regenerate Model – rigenera il modello (solo i comandi del modello: i comandi per l’analisi e la post-elaborazione non vengono rigenerati).
  • Regenerate Model Using Other Files – sostituisce la geometria del modello con una simile proveniente da un altro file, evitando di dover ridefinire il modello (solo i comandi del modello: i comandi per l’analisi e la post-elaborazione non vengono rigenerati).
  • Regenerate Model With Re-meshing – rigenera la mesh del modello mantenendo tutti gli insiemi di nodi, gli insiemi di elementi e i dati delle superfici definiti tramite selezioni basate sulla mesh: il modello può essere rimeshato senza dover ridefinire le selezioni basate sulla geometria (solo i comandi del modello: i comandi per l’analisi e la post-elaborazione non vengono rigenerati).
  • Regenerate All – rigenera il modello (tutti i comandi).
  • Regenerate All Using Other Files – sostituisce la geometria del modello con una simile proveniente da un altro file, evitando di dover ridefinire il modello (tutti i comandi).
  • Regenerate All With Re-meshing – rigenera la mesh del modello mantenendo tutti gli insiemi di nodi, gli insiemi di elementi e i dati delle superfici definiti tramite selezioni basate sulla mesh: il modello può essere rimeshato senza dover ridefinire le selezioni basate sulla geometria (tutti i comandi).

Menu View

Il menu View contiene le seguenti opzioni:

  • Standard Views – applica una delle viste predefinite:
    • Front o Back,
    • Top o Bottom,
    • Left o Right,
    • Normal, – Vertical,
    • Isometric.
  • Zoom to Fit – esegue lo zoom del modello in modo che si adatti alla finestra.
  • Wireframe – applica una vista che mostra solo i bordi del modello.
  • Show Element Edges – applica una vista che mostra il modello con i bordi degli elementi finiti.
  • Show Model Edges – applica una vista che mostra il modello e i bordi delle sue funzioni.
  • No Edges – applica una vista che mostra il modello senza bordi.
  • Section View – taglia il modello con un piano definito da un punto e una normale, oppure disattiva la vista in sezione (questa opzione è disponibile anche in post-elaborazione). Attenzione: anche le parti solide appaiono cave quando si usa la vista in sezione nella scheda Geometry.
  • Exploded View – mostra le parti dell’assieme in vista esplosa; sono disponibili 2 metodi:
    • Default: Exploded view direction, Magnification, Scale factor,
    • Center point: coordinate X/Y/Z, Exploded view direction, Magnification, Scale factor.
  • Show All – mostra (rende visibili) tutte le parti del modello.
  • Hide All – nasconde tutte le parti del modello.
  • Invert Visible Parts – inverte la visibilità delle parti.
  • Undeformed – mostra nei risultati il modello non deformato.
  • Deformed – mostra nei risultati il modello deformato.
  • Deformed With Color Contours – mostra nei risultati il modello deformato con grafico a contour.
  • Deformed & Color & Wireframe – mostra nei risultati il modello deformato con grafico a contour e la rappresentazione wireframe del modello non deformato.
  • Deformed & Color & Solid – mostra nei risultati il modello deformato con grafico a contour e la rappresentazione solida del modello non deformato.
  • Color Annotations – usa i colori per distinguere le entità del modello in base a vari criteri: orientamento delle facce, parti, materiali, sezioni, spessori delle sezioni, tutti i simboli, punti di riferimento, vincoli, coppie di contatto, condizioni al contorno, carichi.

Figura 4: Barra degli strumenti File e View


Alcune opzioni selezionate dai menu File e View sono accessibili direttamente tramite un menu della barra degli strumenti mostrato nella Figura 4. Questa barra degli strumenti contiene anche due pulsanti per le interrogazioni e le annotazioni, che saranno illustrati più avanti.

Menu Tools

Il menu Tools contiene le seguenti opzioni:

  • Settings – per ripristinare tutte le impostazioni predefinite in una qualsiasi delle schede elencate di seguito, faccia clic con il pulsante destro in uno spazio vuoto e selezioni Reset all
  • General
    • Open last file, last file name.
    • Save results in .svx files.
    • Compress .svx files: No compression, Fastest, Optimal.
    • Default unit system.
    • Import mesh → Edge angle.
  • Graphics
    • Background: Type, Top color, Bottom color.
    • Geometry: CAD deflection.
    • Lighting: Ambient component, Diffuse component.
    • Smoothing: Point smoothing, Line smoothing.
    • Widgets: Coordinate system visibility, Scale widget visibility.
  • Default Colors
    • Face orientation: Front face color, Back face color.
    • General.
  • Annotations
    • Design: Background type, Draw a border rectangle, Number format, Number of significant digits
    • Edge/Surface annotation: Show edge/surface id, Show edge/surface type, Show edge/surface size, Show maximum value, Show minimum value, Show sum value, Show average value
    • Node annotation: Show node id, Show coordinates
    • Part annotation: Show part name, Show part id, Show part type, Show number of elements, Show number of nodes
  • Meshing – impostazioni predefinite per la generazione della mesh
    • Mesh size: Mesh size definition, Max element factor, Min element factor, Grading,
    • Elements per edge, Elements per curvature, Hausdorff factor,
    • Mesh optimization: Optimize steps 2D, Optimize steps 3D,
    • Mesh type: Second order, Mid-side nodes on geometry, Quad-dominated mesh,
    • Mesh operations: Split compound mesh, Merge compound parts, Keep model edges.
  • Pre-processing
    • Color bar: Background type, Draw a border rectangle.
    • Selection: Default geometry selection mode, Primary/secondary/mouse highlight color.
    • Symbols: Constraint/Boundary condition/Load color, Symbol size, Node symbol size, Draw symbol edges.
  • Solver
    • Solver: Work directory, Use .svx folder as work directory, Executable, Default solver.
    • Parallelization: Number of processors, Environment variables.
    • Experimental: Convert pyramid elements to (Collapsed wedges/Collapsed hexahedrons)
  • Post-processing
    • Undeformed model
      • Draw undeformed model: None/Wireframe body/Solid body,
      • Colore del modello non deformato.
    • Limit values
      • Show min value location: Yes/No,
      • Show max value location: Yes/No.
    • History output
      • Numero massimo di voci di output di storia.
  • Legend
    • Color spectrum settings
      • Color spectrum type: Cool-warm, Rainbow, Rainbow desaturated, Warm, Cool, Cividis, Viridis, Plasma, Black body, Inferno, KindImann, Grayscale,
      • Brightness,
      • Reverse colors: Sì/No,
      • Numero di colori discreti – nell’intervallo 2-24.
    • Color spectrum values
      • Number format: Scientific/General,
      • Numero di cifre significative – nell’intervallo 2-8, · Min/Max limit type: Automatic/Manual.
    • Design
      • Background type: None/White,
      • Draw a border rectangle: Yes/No.
  • Status Block
    • Design
      • Status block visibility: Yes/No,
      • Background type: None/White,
      • Draw a border rectangle: On/Off.
  • Parameters
    • Name
    • Value/Equation
    • Evaluates to
  • Query
    • Vertex/Node – verifica l’ID del vertice/nodo, le coordinate e il valore dell’output di campo attualmente visualizzato in questo nodo (in Results).
    • Facet/Element – verifica l’ID della sfaccettatura/elemento.
    • Edge – verifica l’ID del bordo e la sua lunghezza, nonché il valore massimo, minimo e totale dell’output di campo attualmente visualizzato lungo questo bordo (in Results).
    • Surface – verifica l’ID della superficie e la sua area, nonché il valore massimo, minimo e totale dell’output di campo attualmente visualizzato su questa superficie (in Results)
    • Part – verifica le informazioni sulla parte (nome, id, tipo, numero di elementi e di nodi).
    • Assembly – verifica il numero di parti, elementi e nodi.
    • Bounding box size – verifica la dimensione del volume di delimitazione del modello.
    • Distance – misura la distanza tra due nodi.
    • Angle – misura l’angolo utilizzando tre punti.
    • Circle – misura il raggio della circonferenza passante per tre punti selezionati.
  • Find
    • Item type: Vertex/Node, Facet/Element, Edge, Surface, Part.
    • Data: Add annotation, Item id.

Attualmente la maggior parte delle annotazioni create con il menu Query visualizza l’output non solo nell’area dei messaggi in fondo alla finestra di Solvix, ma anche sotto forma di etichette collegate al modello. Facendo clic con il pulsante destro su di esse compaiono le opzioni per modificarle manualmente (Edit), ripristinarle (Reset) ed eliminarle (Delete). In questo modo è anche possibile accedere al menu delle impostazioni in cui regolare ulteriormente le annotazioni. Facendo clic sul pulsante Clear in fondo alla finestra Query si eliminano tutte le annotazioni visibili (è possibile visualizzare contemporaneamente più annotazioni di tipo diverso). Sulla barra degli strumenti File e View è inoltre presente un pulsante Remove annotations (Figura 6). Accanto ad esso si trova il pulsante Query, una scorciatoia per Tools Query . Inoltre, le annotazioni vengono salvate nei file .svx.

Lo strumento Find può essere usato per individuare (evidenziare) entità geometriche e della mesh con un ID specificato. Può essere utile, ad esempio, quando si cercano nodi o elementi segnalati come problematici dal solutore.

È possibile definire parametri senza unità di misura e utilizzarli nelle equazioni per la definizione di punti di riferimento, materiali, sezioni, vincoli, carichi e condizioni al contorno. Per aggiungere un’equazione, occorre iniziare il campo di inserimento con il segno di uguale = e rimuovere l’unità di misura dal campo. Le equazioni utilizzano la libreria open source Ncalc e pertanto ne sono supportate le funzioni.