マニュアル / 第2章 – ワークフロー

第2章 – ワークフロー

モデルツリーの 3 つのタブ、一般的な作業手順、各上部メニューの内容。

MANUAL CH. 34節読了 17分更新 2025-10-20

Solvix では、モデルツリーの3つのタブが本ソフトウェアのワークフローを規定します:

  • ジオメトリ – 形状の編集とメッシュ生成、
  • FEMモデル – 解析の設定(プリプロセッシング)、
  • 結果 – ポストプロセッシング。

各タブは、上部ツールバーの適切なメニューも有効にします。

図2: Solvix モデルタブ

Solvix で作業する際に従うべき一般的な手順を以下に示します:

  1. 新しいモデルを作成し( ファイル > 新規 )、モデル空間と単位系を選択します。
  2. 解析用の CAD/STL ジオメトリまたはメッシュをインポートします( ファイル > インポート )。2D 解析では、部品は XY 平面内に完全に存在する面としてインポートする必要があります。また、軸対称解析では、部品を表す面は Y 軸の右側になければなりません。部品名の横に白い感嘆符が付いた黄色の三角形がある場合は、ジオメトリに潜在的な問題があり、調査と修復が必要な可能性があります(Solvix にインポートする前に CAD ソフトウェアで行います)。
  3. CAD および STL ジオメトリの場合は、メッシュ設定を準備し( メッシュ > メッシュ設定項目 > 作成 )、メッシュを生成します( メッシュ > メッシュの作成 )。設定項目なしでもメッシュを生成できます。その場合は既定の設定が使用されます。
  4. メッシュが正常に作成されたら、モデルツリーの FEMモデル 部分に進みます。
  5. 解析用の材料を定義し( 材料 > 作成 )、適切な材料挙動を追加します: 弾性、密度(モーダル解析の実行、または重力や遠心力荷重を使用する場合)、塑性(永久変形を考慮する場合)、熱、またはすべり摩耗。
  6. 先に定義した材料で新しいセクションを作成します( セクション > 作成 )。セクションの種類は、ソリッド(3D または 2D ソリッド要素を使用する場合)、シェル(シェル要素を使用する場合)、メンブレン(メンブレン要素を使用する場合)から選択できます。シェル、メンブレン、または平面応力/ひずみ要素を使用する場合は、板厚も指定する必要があります。部品を選択して、その部品にセクションを割り当てます。
  7. 新しい解析ステップを作成します。ほとんどの場合、ステップの既定の設定で十分です。
  8. 任意: 拘束( 拘束 > 作成 )を作成し、接触を定義し(接触コンテナを展開し、 面相互作用 > 作成 を選択してから 接触ペア > 作成 を選択)、初期条件( 初期条件 > 作成 )、定義済みフィールド( 定義フィールド > 作成 )、および/または振幅( 振幅 > 作成 )を定義します。
  9. 境界条件( 境界条件 > 作成 )と荷重( 荷重 > 作成 )を定義します。いくつかの種類が利用可能で、モデルにさまざまな方法で適用できます(後述)。
  10. 解析を実行し( 解析-1 > 実行 )、終了後に結果を表示できます( 解析-1 > 結果 )。さまざまなポストプロセッシングのオプションについては後述します。

Solvix では、節点セットと要素セット、および面を使用して作業できます。これらは、境界条件、荷重、拘束、または接触を作成する前に定義し、選択した機能の定義で参照できます。ただし、通常はセットや面を先に作成せずに機能を追加する方が好まれます。その場合、機能ウィンドウ内の選択ツールにより、機能の種類に応じてジオメトリまたはメッシュに基づいてエンティティを選択できます。

Solvix で作業する方法は主に2つあります。メニュー(メニューバーと上部ツールバー)で利用可能なオプションを使用するか、モデルツリーで選択します。一部のより高度なオプションは、メニューバーからのみアクセスできます。

Solvix の表示操作:

  • ズーム: マウスホイール;
  • モデルの回転: マウス中ボタンまたはキーボードの矢印キー;
  • パン(モデルの移動): Shift + マウス中ボタン。

部品上の任意の位置でマウス中ボタンを押すと、その位置が画面中央に移動し、回転中心に設定されます。

選択にはマウス左ボタンを使用します(マウスをドラッグすると選択ボックスを使用できます。ボックス内に完全に含まれる項目のみが選択されます)。選択時に Shift を押すとエンティティが追加され、Ctrl を押すと削除されます。

3つのメインタブのそれぞれの上部に検索バーが用意されています。これを使用して、ジオメトリ、FEMモデル、および結果のツリーをフィルタリングできます。

単位を使用する入力フィールドは、単位換算に対応しています。値と表示されている既定の単位を編集して(例えば MPa を GPa に変更)、Enter キーを押すと換算が実行されます。Solvix は値を既定の単位で表示します。

異常終了した場合(Solvix が突然終了した場合)、前回のセッションを復元するためにクラッシュリカバリファイルを使用するかどうかを確認されます。

Solvix は、GUI のプリプロセッシングにまだ実装されていない一部の機能を含む解析のポストプロセッシングに対応しています。すなわち、感度解析や状態変数(SDV)を含むシミュレーションを可視化できます。

図3: Solvix メインツールバー

ファイルメニュー

ファイルメニューには以下のオプションがあります:

  • 新規 ( Ctrl + N ) – 新しいモデルを作成します。モデル空間は、3D、2D 平面応力、2D 平面ひずみ、または 2D 軸対称から選択できます。以下の単位系が利用可能です(単位系を選択すると、組立単位が表示されます):
    • 無単位、
    • m、kg、s、°C – 標準 SI 単位系
    • mm、ton、s、°C – 機械工学で一般的な単位セット
    • m、ton、s、°C、
    • in、lbf · s 2/in、s、°F – ヤードポンド法の単位。
  • 開く ( Ctrl + O ) – 以前に作成したモデル(.svx)、履歴(.svxh)、Solvix の結果(.frd)、または OpenFOAM ファイル(.foam)を開きます
  • 最近使用したファイルを開く – 最近使用したモデルのいずれかを開くか、最近使用したファイルの一覧を消去します。
  • 履歴ファイルの実行 – .svxh ファイルを実行します。
  • インポート ( Ctrl + I ) – 以下のいずれかの形式で保存された CAD ジオメトリ、メッシュ、またはモデルをインポートします:
    • STEP: .stp および .step (ほとんどの場合に推奨)、
    • IGES: .igs および .iges、
    • B-rep: .brep、
    • ステレオリソグラフィ: .stl、
    • ユニバーサル: .unv、
    • Netgen: .vol、
    • Abaqus/Solvix 入力ファイル: .inp、
    • Mmg メッシュ: .mesh。
  • 上書き保存 ( Ctrl + S ) – 現在のモデルの変更を保存します。
  • 名前を付けて保存 – モデルを指定した名前の .svx ファイルとして保存します。
  • エクスポート – 部品/モデルを以下のいずれかの形式でエクスポートします:
    • STEP: .stp、
    • B-rep: .brep、
    • ステレオリソグラフィ: .stl、
    • Solvix 入力ファイル: .inp、
    • Abaqus 入力ファイル(試験的): .inp、
    • Mmg メッシュ: .mesh、
    • 変形メッシュ: .inp (現在の変形倍率に従い、シェル要素を用いた解析で出力が 3D に設定されている場合はソリッド要素をエクスポートします)、
    • 変形の可視化: .stl (現在の変形倍率に従います)。
  • 現在の結果を閉じる – モデルツリーのポストプロセッシング部分で現在表示されている結果を閉じます(結果を含めずに .svx モデルを保存するとファイルサイズが小さくなります)。
  • すべての結果を閉じる – モデルツリーのポストプロセッシング部分のすべての結果を閉じます(結果を含めずに .svx モデルを保存するとファイルサイズが小さくなります)。
  • 終了 ( Ctrl + F4 ) – Solvix を終了します(先にモデルを保存するかどうかを確認されます)。

編集メニュー

編集メニューには以下のオプションがあります:

  • 元に戻す – 直前の操作を取り消します。
  • やり直し – 以前に取り消した操作をやり直します。
  • 履歴の編集 – 履歴エディタを開きます。実行した操作の履歴を表示でき、行の最初の列を選択して Delete キーを押すことで、選択したコマンドのエントリを削除できます。履歴全体は すべて消去 ボタンで削除できます。履歴を変更すると再生成機能の動作が変わるため、慎重に使用してください。履歴は新しいコマンドが追加されるたびに(すなわち、モデルに機能が追加されるたびに)ファイルに保存されるため、非常に長い履歴を消去すると Solvix の応答性の改善に役立つ場合があります。
  • モデルの再生成 – モデルを再生成します(モデルのコマンドのみ。解析およびポストプロセッシングのコマンドは再生成されません)。
  • 別のファイルを使用したモデルの再生成 – モデルのジオメトリを別のファイルの類似したものに置き換えるため、モデルを再定義する必要がありません(モデルのコマンドのみ。解析およびポストプロセッシングのコマンドは再生成されません)。
  • 再メッシュによるモデルの再生成 – メッシュベースの選択で定義したすべての節点セット、要素セット、および面データを保持したままモデルを再メッシュします。ジオメトリベースの選択を再定義せずに再メッシュできます(モデルのコマンドのみ。解析およびポストプロセッシングのコマンドは再生成されません)。
  • すべて再生成 – モデル全体を再生成します(すべてのコマンド)。
  • 別のファイルを使用したすべて再生成 – モデルのジオメトリを別のファイルの類似したものに置き換えるため、モデルを再定義する必要がありません(すべてのコマンド)。
  • 再メッシュによるすべて再生成 – メッシュベースの選択で定義したすべての節点セット、要素セット、および面データを保持したままモデルを再メッシュします。ジオメトリベースの選択を再定義せずに再メッシュできます(すべてのコマンド)。

表示メニュー

表示メニューには以下のオプションがあります:

  • 標準ビュー – 定義済みのビューの1つを適用します:
    • 正面または背面、
    • 上面または下面、
    • 左面または右面、
    • 法線、– 鉛直、
    • アイソメトリック。
  • 全体表示 – モデルがウィンドウに収まるようにズームします。
  • ワイヤーフレーム – モデルのエッジのみを表示するビューを適用します。
  • 要素エッジを表示 – 有限要素のエッジを表示したモデルのビューを適用します。
  • モデルエッジを表示 – モデルとそのフィーチャエッジを表示するビューを適用します。
  • エッジなし – エッジを表示しないモデルのビューを適用します。
  • 断面表示 – 点と法線で定義した平面でモデルを切断するか、断面表示を無効にします(このオプションはポストプロセッシングでも使用できます)。警告: ジオメトリタブで断面表示を使用すると、ソリッド部品でも中空に見えます。
  • 分解表示 – アセンブリの部品を分解表示します。2つの方法があります:
    • 既定: 分解表示の方向、拡大率、倍率、
    • 中心点: X/Y/Z 座標、分解表示の方向、拡大率、倍率。
  • すべて表示 – モデルのすべての部品を表示(非表示解除)します。
  • すべて非表示 – モデルのすべての部品を非表示にします。
  • 表示部品の反転 – 部品の表示状態を反転します。
  • 非変形 – 結果で非変形モデルを表示します。
  • 変形 – 結果で変形モデルを表示します。
  • 変形(カラーコンター) – 結果で変形モデルをコンター図付きで表示します。
  • 変形 & カラー & ワイヤーフレーム – 結果で変形モデルをコンター図付きで、非変形モデルをワイヤーフレーム表現で表示します。
  • 変形 & カラー & ソリッド – 結果で変形モデルをコンター図付きで、非変形モデルをソリッド表現で表示します。
  • 色分け注記 – さまざまな基準(面の向き、部品、材料、セクション、セクションの板厚、すべてのシンボル、基準点、拘束、接触ペア、境界条件、荷重)に基づいて、モデルの項目を色で区別します。

図4: ファイルと表示のツールバー


ファイルメニューと表示メニューの一部のオプションは、図4に示すツールバーメニューから直接アクセスできます。このツールバーには、後述するクエリと注記用の2つのボタンもあります。

ツールメニュー

ツールメニューには以下のオプションがあります:

  • 設定 – 以下に示すいずれかのタブのすべての設定を既定値に戻すには、空白部分を右クリックして すべてリセット を選択します。
  • 一般
    • 前回のファイルを開く、前回のファイル名。
    • 結果を .svx ファイルに保存する。
    • .svx ファイルを圧縮する: 圧縮なし、最速、最適。
    • 既定の単位系。
    • メッシュのインポート → エッジ角度。
  • グラフィックス
    • 背景: 種類、上部の色、下部の色。
    • ジオメトリ: CAD の分割精度(たわみ)。
    • 照明: 環境光の成分、拡散光の成分。
    • スムージング: ポイントスムージング、ラインスムージング。
    • ウィジェット: 座標系の表示、スケールウィジェットの表示。
  • 既定の色
    • 面の向き: 前面の色、背面の色。
    • 一般。
  • 注記
    • デザイン: 背景の種類、境界矩形を描く、数値の形式、有効桁数
    • エッジ/面の注記: エッジ/面の ID を表示、エッジ/面の種類を表示、エッジ/面の寸法を表示、最大値を表示、最小値を表示、合計値を表示、平均値を表示
    • 節点の注記: 節点 ID を表示、座標を表示
    • 部品の注記: 部品名を表示、部品 ID を表示、部品の種類を表示、要素数を表示、節点数を表示
  • メッシュ生成 – メッシュ生成の既定の設定
    • メッシュサイズ: メッシュサイズの定義、最大要素係数、最小要素係数、勾配、
    • エッジあたりの要素数、曲率あたりの要素数、ハウスドルフ係数、
    • メッシュ最適化: 最適化ステップ数 2D、最適化ステップ数 3D、
    • メッシュの種類: 2次、ジオメトリ上の中間節点、四辺形主体メッシュ、
    • メッシュ操作: 複合メッシュを分割、複合部品を統合、モデルエッジを保持。
  • プリプロセッシング
    • カラーバー: 背景の種類、境界矩形を描く。
    • 選択: 既定のジオメトリ選択モード、主/副/マウスハイライトの色。
    • シンボル: 拘束/境界条件/荷重の色、シンボルのサイズ、節点シンボルのサイズ、シンボルのエッジを描く。
  • ソルバー
    • ソルバー: 作業ディレクトリ、.svx フォルダを作業ディレクトリとして使用、実行ファイル、既定のソルバー。
    • 並列化: プロセッサ数、環境変数。
    • 試験的: ピラミッド要素を(つぶれウェッジ/つぶれ六面体)に変換
  • ポストプロセッシング
    • 非変形モデル
      • 非変形モデルを描く: なし/ワイヤーフレーム/ソリッド、
      • 非変形モデルの色。
    • 限界値
      • 最小値の位置を表示: する/しない、
      • 最大値の位置を表示: する/しない。
    • 履歴出力
      • 履歴出力の最大エントリ数。
  • 凡例
    • カラースペクトルの設定
      • カラースペクトルの種類: Cool-warm、Rainbow、Rainbow desaturated、Warm、Cool、Cividis、Viridis、Plasma、Black body、Inferno、KindImann、Grayscale、
      • 明るさ、
      • 色を反転: する/しない、
      • 離散色の数 – 2~24 の範囲。
    • カラースペクトルの値
      • 数値の形式: 科学技術表記/一般表記、
      • 有効桁数 – 2~8 の範囲、· 最小/最大限界の種類: 自動/手動。
    • デザイン
      • 背景の種類: なし/白、
      • 境界矩形を描く: する/しない。
  • ステータスブロック
    • デザイン
      • ステータスブロックの表示: する/しない、
      • 背景の種類: なし/白、
      • 境界矩形を描く: オン/オフ。
  • パラメータ
    • 名前
    • 値/式
    • 評価値
  • クエリ
    • 頂点/節点 – 頂点/節点の ID、座標、およびその節点で現在表示されているフィールド出力の値を確認します(結果で)。
    • 面要素/要素 – 面要素/要素の ID を確認します。
    • エッジ – エッジの ID とその長さ、およびこのエッジに沿って現在表示されているフィールド出力の最大値、最小値、合計値を確認します(結果で)。
    • 面 – 面の ID とその面積、およびこの面で現在表示されているフィールド出力の最大値、最小値、合計値を確認します(結果で)。
    • 部品 – 部品の情報(名前、ID、種類、要素数、節点数)を確認します。
    • アセンブリ – 部品、要素、節点の数を確認します。
    • 境界ボックスのサイズ – モデルの境界ボックスのサイズを確認します。
    • 距離 – 2つの節点間の距離を測定します。
    • 角度 – 3つの点を使用して角度を測定します。
    • 円 – 選択した3点を通る円の半径を測定します。
  • 検索
    • 項目の種類: 頂点/節点、面要素/要素、エッジ、面、部品。
    • データ: 注記を追加、項目 ID。

現在、クエリメニューで作成した注記のほとんどは、Solvix ウィンドウ下部のメッセージ領域に表示されるだけでなく、モデルに付加されたラベルとしても表示されます。ラベルを右クリックすると、編集(表示内容を手動で変更)、リセット、削除のオプションが表示されます。この方法で、注記をさらに調整できる設定メニューにもアクセスできます。クエリウィンドウ下部の クリア ボタンをクリックすると、表示中のすべての注記が削除されます(異なる種類の複数の注記を同時に表示できます)。ファイルと表示のツールバーにも注記の削除ボタンがあります(図6)。その隣には、ツール クエリ のショートカットである クエリ ボタンがあります。さらに、注記は .svx ファイルに保存されます。

検索ツールは、指定した ID を持つジオメトリおよびメッシュのエンティティを特定(ハイライト)するために使用できます。たとえば、ソルバーが問題ありと報告した節点や要素を探す場合に便利です。

無単位のパラメータを定義し、基準点、材料、セクション、拘束、荷重、境界条件の定義における式で参照できます。式を追加するには、入力フィールドを等号 = で始め、フィールドから単位を削除します。式はオープンソースの Ncalc ライブラリを使用しているため、その関数を利用できます。