Manual / Capítulo 2 – Fluxo de trabalho

Capítulo 2 – Fluxo de trabalho

As três abas da árvore do modelo, a ordem geral de trabalho e o conteúdo de cada menu superior.

MANUAL CH. 34 SEÇÕES17 MIN DE LEITURAATUALIZADO EM 2025-10-20

No Solvix, três abas da árvore do modelo determinam o fluxo de trabalho neste software:

  • Geometria – edição de geometria e geração de malha,
  • Modelo FEM – configuração da análise (pré-processamento),
  • Resultados – pós-processamento.

Cada aba também ativa os menus apropriados na barra de ferramentas superior.

Figura 2: Abas de modelo do Solvix

Os passos gerais que devem ser seguidos ao trabalhar no Solvix estão listados abaixo:

  1. Crie um novo modelo ( Arquivo > Novo ) e selecione um espaço de modelo e um sistema de unidades.
  2. Importe geometria CAD/STL ou malha para a análise ( Arquivo > Importar ). Para análises 2D, as peças devem ser importadas como faces situadas inteiramente no plano XY. Além disso, para análises axissimétricas, as faces que representam as peças devem ficar à direita do eixo Y. O triângulo amarelo com ponto de exclamação branco ao lado do nome da peça indica problemas potenciais na geometria que podem exigir investigação e reparo adicionais (no software CAD antes de importar para o Solvix).
  3. Para geometria CAD e STL, prepare a configuração de malha ( Malha > Item de configuração de malha > Criar ) e gere uma malha ( Malha > Criar malha ). A malha também pode ser gerada sem itens de configuração – ela usará as configurações padrão.
  4. Quando a malha for criada com sucesso, prossiga para a parte Modelo FEM da árvore do modelo.
  5. Defina o material para a análise ( Materiais > Criar ), adicione os comportamentos de material adequados: Elasticidade, Densidade (para realizar uma análise modal ou usar cargas de gravidade ou centrífugas), Plasticidade (para considerar deformações permanentes), Térmico ou Desgaste por deslizamento.
  6. Crie uma nova seção com o material definido anteriormente ( Seção > Criar ). O tipo de seção pode ser Sólido (para usar elementos sólidos 3D ou 2D), Casca (para usar elementos de casca) ou Membrana (para usar elementos de membrana). A espessura também deve ser especificada se forem usados elementos de casca, membrana ou de tensão/deformação plana. Selecione a peça à qual atribuir a seção.
  7. Crie um novo passo de análise. As configurações padrão do passo são suficientes na maioria dos casos.
  8. Opcional: crie restrições ( Restrições > Criar ), defina contato (expanda o contêiner Contato, selecione Interações superficiais > Criar e depois selecione Pares de contato > Criar ), condições iniciais ( Condição inicial > Criar ), campos definidos ( Definir campos > Criar ) e/ou amplitudes ( Amplitude > Criar ).
  9. Defina condições de contorno ( CCs > Criar ) e cargas ( Cargas > Criar ). Existem vários tipos disponíveis, e eles podem ser aplicados ao modelo de diferentes maneiras (discutidas mais adiante).
  10. Envie a análise ( Analysis-1 > Executar ); quando ela terminar, os resultados poderão ser visualizados ( Analysis-1 > Resultados ). Várias opções de pós-processamento serão explicadas mais adiante.

No Solvix, é possível trabalhar com conjuntos de nós e de elementos, bem como com superfícies. Eles podem ser definidos antes de criar qualquer condição de contorno, carga, restrição ou contato e depois referenciados na definição do recurso selecionado. No entanto, geralmente é preferível adicionar recursos sem criar conjuntos/superfícies primeiro. Nesses casos, a ferramenta de seleção dentro da janela do recurso permite ao usuário escolher entidades com base na geometria ou na malha, dependendo do tipo de recurso.

Há duas formas principais de trabalhar no Solvix – usar as opções disponíveis nos menus (barra de menus e barra de ferramentas superior) ou selecioná-las na árvore do modelo. Algumas opções mais avançadas só podem ser acessadas pela barra de menus.

Controles de visualização no Solvix:

  • Zoom: rolagem do mouse;
  • Rotacionar modelo: botão do meio do mouse ou setas do teclado;
  • Panorâmica (mover o modelo): Shift + botão do meio do mouse.

Pressionar o botão do meio do mouse em qualquer ponto da peça move esse local para o centro da tela e o define como centro de rotação.

Para selecionar, use o botão esquerdo do mouse (arraste o mouse para usar a caixa de seleção – apenas itens totalmente dentro da caixa são selecionados). Manter Shift pressionado ao selecionar adiciona entidades, enquanto manter Ctrl pressionado as remove.

Uma barra de pesquisa está disponível na parte superior de cada uma das três abas principais. Ela pode ser usada para filtrar as árvores de geometria, Modelo FEM e resultados.

Os campos de entrada que usam unidades suportam conversão. O usuário pode inserir um valor, editar a unidade padrão exibida (por exemplo, alterar MPa para GPa) e a conversão será feita após pressionar Enter; o Solvix exibirá o valor em unidades padrão.

Em caso de falha (quando o Solvix fecha inesperadamente), o usuário é perguntado se um arquivo de recuperação de falha deve ser usado para regenerar a sessão anterior.

O Solvix suporta o pós-processamento de análises com alguns recursos que ainda não estão implementados para pré-processamento na interface gráfica – a saber, análises de sensibilidade e simulações envolvendo variáveis de estado (SDV) podem ser visualizadas.

Figura 3: Barra de ferramentas principal do Solvix

Menu Arquivo

O menu Arquivo contém as seguintes opções:

  • Novo ( Ctrl + N ) – cria um novo modelo. O espaço do modelo pode ser 3D, 2D Tensão Plana, 2D Deformação Plana ou 2D Axissimétrico. Os seguintes sistemas de unidades estão disponíveis (as unidades derivadas são listadas quando um sistema de unidades é selecionado):
    • Sem unidades,
    • m, kg, s, °C – unidades SI padrão,
    • mm, ton, s, °C – conjunto de unidades típico da engenharia mecânica,
    • m, ton, s, °C,
    • in, lbf · s 2/in, s, °F – unidades imperiais.
  • Abrir ( Ctrl + O ) – abre um modelo criado anteriormente (.svx), histórico (.svxh), resultados do Solvix (.frd) ou arquivos OpenFOAM (.foam)
  • Abrir recentes – abre um dos modelos usados recentemente ou limpa a lista de arquivos recentes.
  • Executar arquivos de histórico – executa um arquivo .svxh.
  • Importar ( Ctrl + I ) – importa geometria CAD, malha ou modelo salvos em um dos seguintes formatos:
    • STEP: .stp e .step (recomendado na maioria dos casos),
    • IGES: .igs e .iges,
    • B-rep: .brep,
    • Estereolitografia: .stl,
    • Universal: .unv,
    • Netgen: .vol,
    • Arquivos de entrada Abaqus/Solvix: .inp,
    • Malha Mmg: .mesh.
  • Salvar ( Ctrl + S ) – salva as alterações no modelo atual.
  • Salvar como – salva o modelo como arquivo .svx com um nome especificado.
  • Exportar – exporta a peça/o modelo em um dos seguintes formatos:
    • STEP: .stp,
    • B-rep: .brep,
    • Estereolitografia: .stl,
    • Arquivo de entrada do Solvix: .inp,
    • Arquivo de entrada do Abaqus (experimental): .inp,
    • Malha Mmg: .mesh,
    • Malha deformada: .inp (respeita o fator de escala de deformação atual, exporta elementos sólidos se a saída estiver definida como 3D para análise com elementos de casca),
    • Visualização deformada: .stl (respeita o fator de escala de deformação atual).
  • Fechar resultado atual – fecha os resultados exibidos atualmente na parte de pós-processamento da árvore do modelo (salvar o modelo .svx sem os resultados reduz o tamanho do arquivo).
  • Fechar todos os resultados – fecha todos os resultados da parte de pós-processamento da árvore do modelo (salvar o modelo svx sem os resultados reduz o tamanho do arquivo).
  • Sair ( Ctrl + F4 ) – fecha o Solvix (o usuário será perguntado se o modelo deve ser salvo primeiro).

Menu Editar

O menu Editar contém as seguintes opções:

  • Desfazer – desfaz a última ação.
  • Refazer – refaz a ação desfeita anteriormente.
  • Editar histórico – abre o editor de histórico, permitindo visualizar o histórico das operações realizadas e excluir as entradas de comando selecionadas escolhendo a primeira coluna da linha e pressionando a tecla Delete. Todo o histórico pode ser excluído usando o botão Limpar tudo. Alterar o histórico alterará a funcionalidade Regenerar, por isso deve ser usado com cautela. Limpar um histórico muito longo pode ajudar na capacidade de resposta do Solvix, já que o histórico é salvo em um arquivo após cada novo comando adicionado a ele (ou seja, após cada recurso adicionado ao modelo).
  • Regenerar modelo – regenera o modelo (apenas comandos de modelo – comandos de análise e pós-processamento não são regenerados).
  • Regenerar modelo usando outros arquivos – substitui a geometria do modelo por uma semelhante de outro arquivo, para que não seja necessário redefinir o modelo (apenas comandos de modelo – comandos de análise e pós-processamento não são regenerados).
  • Regenerar modelo com remalhagem – remalha o modelo mantendo todos os conjuntos de nós, conjuntos de elementos e dados de superfície definidos usando seleções baseadas na malha – o modelo pode ser remalhado sem a necessidade de redefinir as seleções baseadas na geometria (apenas comandos de modelo – comandos de análise e pós-processamento não são regenerados).
  • Regenerar tudo – regenera o modelo (todos os comandos).
  • Regenerar tudo usando outros arquivos – substitui a geometria do modelo por uma semelhante de outro arquivo, para que não seja necessário redefinir o modelo (todos os comandos).
  • Regenerar tudo com remalhagem – remalha o modelo mantendo todos os conjuntos de nós, conjuntos de elementos e dados de superfície definidos usando seleções baseadas na malha – o modelo pode ser remalhado sem a necessidade de redefinir as seleções baseadas na geometria (todos os comandos).

Menu Visualizar

O menu Visualizar contém as seguintes opções:

  • Vistas padrão – aplica uma das vistas predefinidas:
    • Frontal ou Traseira,
    • Superior ou Inferior,
    • Esquerda ou Direita,
    • Normal, – Vertical,
    • Isométrica.
  • Zoom para ajustar – amplia o modelo de modo que ele caiba na janela.
  • Estrutura de arame – aplica uma visualização mostrando apenas as arestas do modelo.
  • Mostrar arestas dos elementos – aplica uma visualização mostrando o modelo com as arestas dos elementos finitos.
  • Mostrar arestas do modelo – aplica uma visualização mostrando o modelo e suas arestas de recurso.
  • Sem arestas – aplica uma visualização mostrando o modelo sem arestas.
  • Vista de seção – corta o modelo usando um plano definido por um ponto e uma normal, ou desativa a vista de seção (esta opção também pode ser usada no pós-processamento) – atenção: mesmo peças sólidas parecem ocas ao usar a vista de seção na aba Geometria.
  • Vista explodida – mostra as peças da montagem em uma vista explodida – 2 métodos disponíveis:
    • Padrão: Direção da vista explodida, Ampliação, Fator de escala,
    • Ponto central: coordenadas X/Y/Z, Direção da vista explodida, Ampliação, Fator de escala.
  • Mostrar tudo – mostra (reexibe) todas as peças do modelo.
  • Ocultar tudo – oculta todas as peças do modelo.
  • Inverter peças visíveis – inverte a visibilidade das peças.
  • Não deformado – mostra o modelo não deformado nos resultados.
  • Deformado – mostra o modelo deformado nos resultados.
  • Deformado com contornos coloridos – mostra o modelo deformado com gráfico de contornos nos resultados.
  • Deformado & Cor & Estrutura de arame – mostra o modelo deformado com gráfico de contornos e representação em estrutura de arame do modelo não deformado nos resultados.
  • Deformado & Cor & Sólido – mostra o modelo deformado com gráfico de contornos e representação sólida do modelo não deformado nos resultados.
  • Anotações coloridas – usa cores para distinguir itens do modelo com base em vários critérios: orientações de face, peças, materiais, seções, espessuras de seção, todos os símbolos, pontos de referência, restrições, pares de contato, CCs, cargas.

Figura 4: Barra de ferramentas Arquivo e Visualizar


Opções selecionadas nos menus Arquivo e Visualizar podem ser acessadas diretamente por meio de um menu de barra de ferramentas mostrado na Figura 4. Esta barra de ferramentas também contém dois botões para consultas e anotações, que serão discutidos mais adiante.

Menu Ferramentas

O menu Ferramentas contém as seguintes opções:

  • Configurações – para redefinir todas as configurações, em qualquer uma das abas listadas abaixo, para os padrões, clique com o botão direito no espaço vazio e selecione Redefinir tudo
  • Geral
    • Abrir último arquivo, nome do último arquivo.
    • Salvar resultados em arquivos .svx.
    • Compactar arquivos .svx: Sem compactação, Mais rápido, Ideal.
    • Sistema de unidades padrão.
    • Importar malha → Ângulo de aresta.
  • Gráficos
    • Fundo: Tipo, Cor superior, Cor inferior.
    • Geometria: Deflexão CAD.
    • Iluminação: Componente ambiente, Componente difusa.
    • Suavização: Suavização de pontos, Suavização de linhas.
    • Widgets: Visibilidade do sistema de coordenadas, Visibilidade do widget de escala.
  • Cores padrão
    • Orientação da face: Cor da face frontal, Cor da face traseira.
    • Geral.
  • Anotações
    • Design: Tipo de fundo, Desenhar um retângulo de borda, Formato numérico, Número de dígitos significativos
    • Anotação de aresta/superfície: Mostrar id de aresta/superfície, Mostrar tipo de aresta/superfície, Mostrar tamanho de aresta/superfície, Mostrar valor máximo, Mostrar valor mínimo, Mostrar valor da soma, Mostrar valor médio
    • Anotação de nó: Mostrar id de nó, Mostrar coordenadas
    • Anotação de peça: Mostrar nome da peça, Mostrar id da peça, Mostrar tipo de peça, Mostrar número de elementos, Mostrar número de nós
  • Malhagem – configurações padrão para malhagem
    • Tamanho da malha: Definição do tamanho da malha, Fator máximo de elemento, Fator mínimo de elemento, Graduação,
    • Elementos por aresta, Elementos por curvatura, Fator de Hausdorff,
    • Otimização da malha: Etapas de otimização 2D, Etapas de otimização 3D,
    • Tipo de malha: Segunda ordem, Nós intermediários na geometria, Malha dominada por quadriláteros,
    • Operações de malha: Dividir malha composta, Mesclar peças compostas, Manter arestas do modelo.
  • Pré-processamento
    • Barra de cores: Tipo de fundo, Desenhar um retângulo de borda.
    • Seleção: Modo padrão de seleção de geometria, Cor de destaque primária/secundária/do mouse.
    • Símbolos: Cor de restrição/condição de contorno/carga, Tamanho do símbolo, Tamanho do símbolo de nó, Desenhar arestas dos símbolos.
  • Solver
    • Solver: Diretório de trabalho, Usar a pasta .svx como diretório de trabalho, Executável, Solver padrão.
    • Paralelização: Número de processadores, Variáveis de ambiente.
    • Experimental: Converter elementos piramidais em (Cunhas colapsadas/Hexaedros colapsados)
  • Pós-processamento
    • Modelo não deformado
      • Desenhar modelo não deformado: Nenhum/Corpo em estrutura de arame/Corpo sólido,
      • Cor do modelo não deformado.
    • Limitar valores
      • Mostrar local do valor mínimo: Sim/Não,
      • Mostrar local do valor máximo: Sim/Não.
    • Saída de histórico
      • Máximo de entradas na saída de histórico.
  • Legenda
    • Configurações do espectro de cores
      • Tipo de espectro de cores: Frio-quente, Arco-íris, Arco-íris dessaturado, Quente, Frio, Cividis, Viridis, Plasma, Corpo negro, Inferno, KindImann, Escala de cinza,
      • Brilho,
      • Inverter cores: Sim/Não,
      • Número de cores discretas – no intervalo de 2 a 24.
    • Valores do espectro de cores
      • Formato numérico: Científico/Geral,
      • Número de dígitos significativos – no intervalo de 2 a 8, · Tipo de limite mín./máx.: Automático/Manual.
    • Design
      • Tipo de fundo: Nenhum/Branco,
      • Desenhar um retângulo de borda: Sim/Não.
  • Bloco de status
    • Design
      • Visibilidade do bloco de status: Sim/Não,
      • Tipo de fundo: Nenhum/Branco,
      • Desenhar um retângulo de borda: Ativado/Desativado.
  • Parâmetros
    • Nome
    • Valor/Equação
    • Avalia como
  • Consulta
    • Vértice/Nó – verifica o ID do vértice/nó, as coordenadas e o valor da saída de campo atualmente exibida neste nó (em Resultados).
    • Faceta/Elemento – verifica o ID da faceta/elemento.
    • Aresta – verifica o ID da aresta e seu comprimento, bem como o valor máximo, mínimo e total da saída de campo atualmente exibida ao longo desta aresta (em Resultados).
    • Superfície – verifica o ID da superfície e sua área, bem como o valor máximo, mínimo e total da saída de campo atualmente exibida nesta superfície (em Resultados)
    • Peça – verifica as informações da peça (nome, id, tipo, número de elementos e nós).
    • Montagem – verifica o número de peças, elementos e nós.
    • Tamanho da caixa delimitadora – verifica o tamanho da caixa delimitadora do modelo.
    • Distância – mede a distância entre dois nós.
    • Ângulo – mede o ângulo usando três pontos.
    • Círculo – mede o raio do círculo que passa por três pontos selecionados.
  • Localizar
    • Tipo de item: Vértice/Nó, Faceta/Elemento, Aresta, Superfície, Peça.
    • Dados: Adicionar anotação, ID do item.

Atualmente, a maioria das anotações criadas usando o menu Consulta exibe a saída não apenas na área de mensagens na parte inferior da janela do Solvix, mas também na forma de rótulos anexados ao modelo. Clicar com o botão direito sobre eles mostra as opções de Editar (alterar manualmente o conteúdo exibido), Redefinir e Excluir. Dessa forma, também é possível acessar o menu de configurações, onde as anotações podem ser ajustadas ainda mais. Clicar no botão Limpar na parte inferior da janela Consulta exclui todas as anotações visíveis (é possível exibir várias anotações de tipos diferentes ao mesmo tempo). Há também um botão Remover anotações na barra de ferramentas Arquivo e Visualizar (Figura 6). Ao lado dele, há um botão Consulta, um atalho para Ferramentas Consulta . Além disso, as anotações são salvas em arquivos .svx.

A ferramenta Localizar pode ser usada para localizar (destacar) entidades geométricas e de malha com um ID especificado. Ela pode ser útil, por exemplo, ao procurar nós ou elementos relatados como problemáticos pelo solver.

Parâmetros sem unidades podem ser definidos e depois usados em equações para definições de pontos de referência, materiais, seções, restrições, cargas e condições de contorno. Para adicionar uma equação, deve-se iniciar o campo de entrada com o sinal de igual = e excluir a unidade do campo. As equações usam a biblioteca de código aberto Ncalc e, portanto, suas funções são suportadas.