Manuel / Chapitre 2 – Flux de travail

Chapitre 2 – Flux de travail

Les trois onglets de l'arbre de modèle, l'ordre de travail général et le contenu de chaque menu supérieur.

MANUAL CH. 34 SECTIONS17 MIN DE LECTUREMIS À JOUR LE 2025-10-20

Dans Solvix, trois onglets de l’arborescence du modèle définissent le flux de travail du logiciel :

  • Geometry – édition de la géométrie et génération du maillage,
  • FEM Model – configuration de l’analyse (prétraitement),
  • Results – post-traitement.

Chaque onglet active également les menus correspondants dans la barre d’outils supérieure.

Figure 2 : Onglets du modèle Solvix

Les étapes générales à suivre lorsque vous travaillez dans Solvix sont listées ci-dessous :

  1. Créez un nouveau modèle ( File > New ) et sélectionnez un espace de modèle et un système d’unités.
  2. Importez une géométrie ou un maillage CAO/STL pour l’analyse ( File > Import ). Pour les analyses 2D, les pièces doivent être importées sous forme de faces situées entièrement dans le plan XY. En outre, pour les analyses axisymétriques, les faces représentant les pièces doivent se trouver à droite de l’axe Y.
  3. Pour une géométrie CAO ou STL, préparez la configuration du maillage ( Mesh > Mesh Setup Item > Create ) et générez un maillage ( Mesh > Create Mesh ). Le maillage peut aussi être généré sans élément de configuration : les paramètres par défaut seront alors utilisés.
  4. Une fois le maillage créé avec succès, passez à la partie FEM Model de l’arborescence du modèle.
  5. Définissez le matériau pour l’analyse ( Materials > Create ) et ajoutez les comportements de matériau adéquats : Elasticity, Density (pour une analyse modale ou l’utilisation de la gravité ou de charges centrifuges), Plasticity (pour tenir compte des déformations permanentes), Thermal ou Slip wear (usure par glissement).
  6. Créez une nouvelle section avec le matériau défini précédemment ( Section > Create ). Le type de section peut être Solid (pour les éléments volumiques 3D ou 2D), Shell (pour les éléments de coque) ou Membrane (pour les éléments de membrane). L’épaisseur doit également être spécifiée.
  7. Créez un nouveau pas d’analyse. Les paramètres par défaut du pas suffisent dans la plupart des cas.
  8. Facultatif : créez des liaisons ( Constraints > Create ), définissez le contact (développez le conteneur Contact, sélectionnez Surface Interactions > Create puis Contact pairs > Create ), les conditions initiales ( Initial condition > Create ), les champs définis ( Define fields > Create ) et/ou les amplitudes ( Amplitude > Create ).
  9. Définissez les conditions aux limites ( BCs > Create ) et les charges ( Loads > Create ). Plusieurs types sont disponibles et peuvent être appliqués au modèle de différentes manières (voir plus loin).
  10. Lancez l’analyse ( Analysis-1 > Run ) ; une fois terminée, les résultats peuvent être visualisés ( Analysis-1 > Results ). Les différentes options de post-traitement sont expliquées plus loin.

Dans Solvix, il est possible de travailler avec des ensembles de nœuds et d’éléments, ainsi qu’avec des surfaces. Ils peuvent être définis avant toute création de condition aux limites, de charge, de liaison ou de contact, puis référencés dans la définition de la fonctionnalité sélectionnée.

Il existe deux manières principales de travailler dans Solvix : utiliser les options des menus (barre de menus et barre d’outils supérieure) ou les sélectionner dans l’arborescence du modèle. Certaines options plus avancées ne sont accessibles que depuis la barre de menus.

Commandes d’affichage dans Solvix :

  • Zoom : molette de la souris ;
  • Rotation du modèle : bouton central de la souris ou flèches du clavier ;
  • Panoramique (déplacement du modèle) : Maj + bouton central de la souris.

Un appui sur le bouton central de la souris n’importe où sur la pièce déplace ce point au centre de l’écran et le définit comme centre de rotation.

Pour la sélection, utilisez le bouton gauche de la souris (faites glisser la souris pour utiliser le rectangle de sélection : seuls les éléments entièrement à l’intérieur du rectangle sont sélectionnés). Maintenir Maj pendant la sélection ajoute des entités, tandis que maintenir Ctrl les retire.

Une barre de recherche est disponible en haut de chacun des trois onglets principaux. Elle permet de filtrer les arborescences de géométrie, de modèle éléments finis et de résultats.

Les champs de saisie avec unités prennent en charge la conversion. L’utilisateur peut saisir une valeur, modifier l’unité affichée par défaut (par exemple passer de MPa à GPa) ; la conversion est effectuée après avoir appuyé sur Entrée et Solvix affiche la valeur dans les unités par défaut.

En cas de défaillance (fermeture inattendue de Solvix), il est demandé à l’utilisateur si un fichier de récupération après plantage doit être utilisé pour régénérer la session précédente.

Solvix prend en charge le post-traitement d’analyses comportant certaines fonctionnalités qui ne sont pas encore implémentées dans l’interface graphique pour le prétraitement : les analyses de sensibilité et les simulations impliquant des variables d’état (SDV) peuvent notamment être visualisées.

Figure 3 : Barre d’outils principale de Solvix

Menu File

Le menu File contient les options suivantes :

  • New ( Ctrl + N ) – crée un nouveau modèle. L’espace de modèle peut être 3D, 2D Plane Stress, 2D Plane Strain ou 2D Axisymmetric. Les systèmes d’unités suivants sont disponibles (les unités dérivées sont listées lorsqu’un système d’unités est sélectionné) :
    • Sans unité,
    • m, kg, s, °C – unités SI standard,
    • mm, ton, s, °C – jeu d’unités courant en construction mécanique,
    • m, ton, s, °C,
    • in, lbf · s 2/in, s, °F – unités impériales.
  • Open ( Ctrl + O ) – ouvre un modèle précédemment créé (.svx), un historique (.svxh), des résultats Solvix (.frd) ou des fichiers OpenFOAM (.foam)
  • Open Recent – ouvre l’un des modèles récemment utilisés ou efface la liste des fichiers récents.
  • Run History Files – exécute un fichier .svxh.
  • Import ( Ctrl + I ) – importe une géométrie CAO, un maillage ou un modèle enregistré dans l’un des formats suivants :
    • STEP : .stp et .step (recommandé dans la plupart des cas),
    • IGES : .igs et .iges,
    • B-rep : .brep,
    • Stéréolithographie : .stl,
    • Universal : .unv,
    • Netgen : .vol,
    • Fichiers d’entrée Abaqus/Solvix : .inp,
    • Maillage Mmg : .mesh.
  • Save ( Ctrl + S ) – enregistre les modifications du modèle courant.
  • Save As – enregistre le modèle sous forme de fichier .svx avec un nom donné.
  • Export – exporte la pièce ou le modèle dans l’un des formats suivants :
    • STEP : .stp,
    • B-rep : .brep,
    • Stéréolithographie : .stl,
    • Fichier d’entrée Solvix : .inp,
    • Fichier d’entrée Abaqus (expérimental) : .inp,
    • Maillage Mmg : .mesh,
    • Maillage déformé : .inp (respecte le facteur d’échelle de déformation courant, exporte les éléments volumiques si la sortie est réglée sur 3D pour une analyse avec des éléments de coque),
    • Visualisation déformée : .stl (respecte le facteur d’échelle de déformation courant).
  • Close Current Result – ferme les résultats affichés actuellement depuis la partie post-traitement de l’arborescence du modèle (enregistrer le modèle .svx sans les résultats réduit la taille du fichier).
  • Close All Results – ferme tous les résultats de la partie post-traitement de l’arborescence du modèle (enregistrer le modèle svx sans les résultats réduit la taille du fichier).
  • Exit ( Ctrl + F4 ) – ferme Solvix (il est demandé à l’utilisateur si le modèle doit d’abord être enregistré).

Menu Edit

Le menu Edit contient les options suivantes :

  • Undo – annule la dernière action.
  • Redo – rétablit l’action précédemment annulée.
  • Edit History – ouvre l’éditeur d’historique, qui permet de consulter l’historique des opérations effectuées et de supprimer les entrées de commande sélectionnées en choisissant la première colonne de la ligne et en appuyant sur la touche Suppr. Tout l’historique peut être supprimé.
  • Regenerate Model – régénère le modèle (uniquement les commandes de modèle ; les commandes d’analyse et de post-traitement ne sont pas régénérées).
  • Regenerate Model Using Other Files – remplace la géométrie du modèle par une géométrie similaire issue d’un autre fichier afin de ne pas avoir à redéfinir le modèle (uniquement les commandes de modèle ; les commandes d’analyse et de post-traitement ne sont pas régénérées).
  • Regenerate Model With Re-meshing – remailler le modèle tout en conservant tous les ensembles de nœuds, ensembles d’éléments et données de surface définis à partir de sélections basées sur le maillage : le modèle peut être remaillé sans avoir à redéfinir les sélections basées sur la géométrie (uniquement les commandes de modèle).
  • Regenerate All – régénère le modèle (toutes les commandes).
  • Regenerate All Using Other Files – remplace la géométrie du modèle par une géométrie similaire issue d’un autre fichier afin de ne pas avoir à redéfinir le modèle (toutes les commandes).
  • Regenerate All With Re-meshing – remailler le modèle tout en conservant tous les ensembles de nœuds, ensembles d’éléments et données de surface définis à partir de sélections basées sur le maillage : le modèle peut être remaillé sans avoir à redéfinir les sélections basées sur la géométrie (toutes les commandes).

Menu View

Le menu View contient les options suivantes :

  • Standard Views – applique l’une des vues prédéfinies :
    • Avant ou arrière,
    • Dessus ou dessous,
    • Gauche ou droite,
    • Normale, – Verticale,
    • Isométrique.
  • Zoom to Fit – effectue un zoom de sorte que le modèle tienne dans la fenêtre.
  • Wireframe – applique une vue montrant uniquement les arêtes du modèle.
  • Show Element Edges – applique une vue montrant le modèle avec les arêtes des éléments finis.
  • Show Model Edges – applique une vue montrant le modèle et ses arêtes de forme.
  • No Edges – applique une vue montrant le modèle sans arêtes.
  • Section View – coupe le modèle à l’aide d’un plan défini par un point et une normale, ou désactive la vue en coupe (cette option peut aussi être utilisée en post-traitement) – attention : même les pièces volumiques apparaissent creuses lors de l’utilisation de la vue en coupe dans l’onglet Geometry.
  • Exploded View – affiche les pièces de l’assemblage en vue éclatée – 2 méthodes disponibles :
    • Default : Exploded view direction, Magnification, Scale factor,
    • Center point : coordonnées X/Y/Z, Exploded view direction, Magnification, Scale factor.
  • Show All – affiche (rend visibles) toutes les pièces du modèle.
  • Hide All – masque toutes les pièces du modèle.
  • Invert Visible Parts – inverse la visibilité des pièces.
  • Undeformed – affiche le modèle non déformé dans les résultats.
  • Deformed – affiche le modèle déformé dans les résultats.
  • Deformed With Color Contours – affiche le modèle déformé avec un tracé de courbes de niveau dans les résultats.
  • Deformed & Color & Wireframe – affiche le modèle déformé avec un tracé de courbes de niveau et une représentation filaire du modèle non déformé dans les résultats.
  • Deformed & Color & Solid – affiche le modèle déformé avec un tracé de courbes de niveau et une représentation volumique du modèle non déformé dans les résultats.
  • Color Annotations – utilise des couleurs pour distinguer les éléments du modèle selon différents critères : orientations des faces, pièces, matériaux, sections, épaisseurs de section, tous les symboles, points de référence, liaisons, paires de contact, conditions aux limites, charges.

Figure 4 : Barre d’outils File et View


Certaines options des menus File et View sont accessibles directement depuis un menu de barre d’outils représenté sur la figure 4. Cette barre d’outils contient également deux boutons pour les requêtes et les annotations, qui sont décrits plus loin.

Menu Tools

Le menu Tools contient les options suivantes :

  • Settings – pour réinitialiser tous les paramètres de l’un des onglets listés ci-dessous aux valeurs par défaut, cliquez avec le bouton droit dans la zone vide et sélectionnez Reset all
  • Général
    • Ouvrir le dernier fichier, nom du dernier fichier.
    • Enregistrer les résultats dans les fichiers .svx.
    • Compresser les fichiers .svx : No compression, Fastest, Optimal.
    • Système d’unités par défaut.
    • Import mesh → Edge angle.
  • Graphiques
    • Background : Type, Top color, Bottom color.
    • Geometry : CAD deflection.
    • Lighting : Ambient component, Diffuse component.
    • Smoothing : Point smoothing, Line smoothing.
    • Widgets : Coordinate system visibility, Scale widget visibility.
  • Couleurs par défaut
    • Face orientation : Front face color, Back face color.
    • Général.
  • Annotations
    • Design : Background type, Draw a border rectangle, Number format, Number of significant digits
    • Edge/Surface annotation : Show edge/surface id, Show edge/surface type, Show edge/surface size, Show maximum value, Show minimum value, Show sum value, Show average value
    • Node annotation : Show node id, Show coordinates
    • Part annotation : Show part name, Show part id, Show part type, Show number of elements, Show number of nodes
  • Maillage – paramètres par défaut pour le maillage
    • Mesh size : Mesh size definition, Max element factor, Min element factor, Grading,
    • Elements per edge, Elements per curvature, Hausdorff factor,
    • Mesh optimization : Optimize steps 2D, Optimize steps 3D,
    • Mesh type : Second order, Mid-side nodes on geometry, Quad-dominated mesh,
    • Mesh operations : Split compound mesh, Merge compound parts, Keep model edges.
  • Prétraitement
    • Color bar : Background type, Draw a border rectangle.
    • Selection : Default geometry selection mode, Primary/secondary/mouse highlight color.
    • Symbols : Constraint/Boundary condition/Load color, Symbol size, Node symbol size, Draw symbol edges.
  • Solveur
    • Solver : Work directory, Use .svx folder as work directory, Executable, Default solver.
    • Parallelization : Number of processors, Environment variables.
    • Experimental : Convert pyramid elements to (Collapsed wedges/Collapsed hexahedrons)
  • Post-traitement
    • Modèle non déformé
      • Draw undeformed model : None/Wireframe body/Solid body,
      • Couleur du modèle non déformé.
    • Valeurs limites
      • Show min value location : Yes/No,
      • Show max value location : Yes/No.
    • Sortie d’historique
      • Nombre maximal d’entrées de sortie d’historique.
  • Légende
    • Paramètres du spectre de couleurs
      • Color spectrum type : Cool-warm, Rainbow, Rainbow desaturated, Warm, Cool, Cividis, Viridis, Plasma, Black body, Inferno, KindImann, Grayscale,
      • Luminosité,
      • Reverse colors : Yes/No,
      • Nombre de couleurs discrètes – dans la plage 2-24.
    • Valeurs du spectre de couleurs
      • Number format : Scientific/General,
      • Nombre de chiffres significatifs – dans la plage 2-8, · Min/Max limit type : Automatic/Manual.
    • Design
      • Background type : None/White,
      • Draw a border rectangle : Yes/No.
  • Bloc d’état
    • Design
      • Status block visibility : Yes/No,
      • Background type : None/White,
      • Draw a border rectangle : On/Off.
  • Paramètres
    • Nom
    • Valeur/équation
    • Évalué à
  • Requête
    • Vertex/Node – vérifie l’identifiant et les coordonnées du sommet/du nœud ainsi que la valeur de la sortie de champ affichée actuellement en ce nœud (dans Results).
    • Facet/Element – vérifie l’identifiant de la facette/de l’élément.
    • Edge – vérifie l’identifiant de l’arête et sa longueur, ainsi que les valeurs maximale, minimale et totale de la sortie de champ affichée actuellement le long de cette arête (dans Results).
    • Surface – vérifie l’identifiant de la surface et son aire, ainsi que les valeurs maximale, minimale et totale de la sortie de champ affichée actuellement sur cette surface (dans Results)
    • Part – vérifie les informations de la pièce (nom, identifiant, type, nombre d’éléments et de nœuds).
    • Assembly – vérifie le nombre de pièces, d’éléments et de nœuds.
    • Bounding box size – vérifie la taille de la boîte englobante du modèle.
    • Distance – mesure la distance entre deux nœuds.
    • Angle – mesure l’angle à l’aide de trois points.
    • Circle – mesure le rayon du cercle passant par trois points sélectionnés.
  • Rechercher
    • Item type : Vertex/Node, Facet/Element, Edge, Surface, Part.
    • Data : Add annotation, Item id.

Actuellement, la plupart des annotations créées via le menu Query sont affichées non seulement dans la zone de messages en bas de la fenêtre Solvix, mais aussi sous forme d’étiquettes attachées au modèle.

L’outil Find permet de localiser (mettre en surbrillance) des entités géométriques et de maillage ayant un identifiant donné. Il peut être utile, par exemple, pour rechercher les nœuds ou éléments signalés comme problématiques par le solveur.

Des paramètres sans unité peuvent être définis puis utilisés dans des équations pour la définition des points de référence, des matériaux, des sections, des liaisons, des charges et des conditions aux limites. Pour ajouter une équation, commencez la saisie dans le champ correspondant.